Closed Bug 368346 Opened 14 years ago Closed 2 years ago

xul tree table needs cell navigation

Categories

(Core :: XUL, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: monsanto, Assigned: janv)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: orca:normal)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: version 3 alpha 1 (20070126)

Currently, focus is not on the first cell of a message header row. It's generally on the last. This is an inconvenience for Braille users, since they always need to navigate back to the first cell.

Reproducible: Always

Steps to Reproduce:
1. Enable accessibility on the desktop
2. Give focus to a message header row.
3. Start at-poke and examine the last cell in a table header row. You will see its state is focused.
Actual Results:  
See above.

Expected Results:  
See above.
Keywords: access, sec508
Currently the focused cell is the cell in the sorted column.
I guess the last cell is focused is because messages are sorted by "Date", which is often the last column.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Lynn, if this can't easily be changed in Thunderbird please just change the braille line to start showing braille from the virst showing cell instead of showing from the cell with focus.  
Wow...this sure seemed to get closed as INVALID awfully quickly and with zero discussion.  We file bugs because we have usability problems.  I'm reopening this bug since I'd appreciate more discussion on it.

Is there a way for the user to navigate from cell to cell?  For example, when reading e-mail in Evolution, one can move between cells using Ctrl+Left and Ctrl+Right.
Darn...I guess I cannot reopen it for some odd reason.
reopen the bug for Will.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Please note that I closing this bug doesn't imply anything about prevent discussion from it. It's free to reopen the bug if there is
different opinions. Ideas and discussions are highly welcome!  :) 

It's just what I think the way bugzilla works. If I was wrong, please
correct me.
(In reply to comment #3)
> Is there a way for the user to navigate from cell to cell?  For example, when
> reading e-mail in Evolution, one can move between cells using Ctrl+Left and
> Ctrl+Right.
> 
I think the answer is no, because thunderbird messages list is row selection.
Is Orca flat review suitable for the scenario?
(In reply to comment #7)
> (In reply to comment #3)
> > Is there a way for the user to navigate from cell to cell?  For example, when
> > reading e-mail in Evolution, one can move between cells using Ctrl+Left and
> > Ctrl+Right.
> > 
> I think the answer is no, because thunderbird messages list is row selection.
> Is Orca flat review suitable for the scenario?

Flat review is usually only a fallback to handle inadequate application behavior or to explore the layout of an unknown dialogs.  Instead of relying on flat review, we really like to see good navigation built into the application.

What we typically like to see for tables such as the messages list in Thunderbird is the ability to treat the table like a bunch of individual cells, each with its own column header.  If the message list shows the entire row as being selected, it's fine and actually arguably desirable.  But..we'd like to keep the notion of a single cell that can be the selected cell, and we'd like to allow the user to change this via keystrokes such as Ctrl+Left and Ctrl+Right.  Evolution does this and it works great. We also see similar behavior in other tables in GTK.

In Orca, we provide the option to speak all the cells on a row or just the cell with focus on the row when the user arrows up and down.  This option is also quickly toggleable via an Orca keystroke.  The "speak just the cell with focus" option allows a user to quickly move up and down through whatever column it is that they might care about (e.g., "let me just scan the subject lines").  The "speak the entire row" option allows the user to get a full summary of each line.  Furthermore, the current cell with focus tends to be positioned at a consistent braille cell offset on the braille display, thus providing the user with a better experience when moving between the keyboard and braille display.  All these combined make for a good user experience.

Most people I know of view Thunderbird as being a much better alternative to Evolution.  But...it seems as though Thunderbird might be behind in this one area.  Is there a way to improve it to provide simple cell navigation in the message list?
Thanks for explanation, Will! Now I understand the scenario better.
It seems the key problem is that we need a cell navigation in xul tree table.

I'm changing the subject and cc-ing Aaron for comments.
Assignee: mscott → aaronleventhal
Component: Mail Window Front End → Disability Access APIs
Product: Thunderbird → Core
QA Contact: front-end → accessibility-apis
Summary: message header list focus should be on the first cell in the row. → xul tree table needs cell navigation
Version: unspecified → Trunk
Couple of questions:
Is this navigation mode consistent with what tree views on the platform?
Is it a navigation mode necessary for non-screenreader users?

If no to both, then I think this may be a feature for review mode -- similar to table navigation in HTML documents.
(In reply to comment #10)
> Couple of questions:
> Is this navigation mode consistent with what tree views on the platform?
> Is it a navigation mode necessary for non-screenreader users?
> 
> If no to both, then I think this may be a feature for review mode -- similar to
> table navigation in HTML documents.

This navigation mode is provided by Evolution and also by GNOME tables/lists.  The "focus on the cell whose column is sorted" behavior is definitely a unique/unexpected behavior as far as I've seen.
Well then we need this at least on Gnome -- XUL widgets need to act like their counterparts on the desktop environment they are running in.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: aaronleventhal → Jan.Varga
Component: Disability Access APIs → XP Toolkit/Widgets: Trees
QA Contact: accessibility-apis → xptoolkit.trees
Is this bug requesting any additional xul feature? XUL already supports cell navigation. (seltype="cell"). Otherwise this should be a Thunderbird bug.
Neil,
As my understanding, seltype="cell" makes xul tree table become cell selection. Currently, messages list of Thunderbird is row selection, which is good. I think what Orca team calls for is a selection mechanism besides current row selection, in order to know which cell of the selected row is focused.
I think someone needs to provide an example of an app which has this, and explain how to use it (what keys etc.)
(In reply to comment #15)
> I think someone needs to provide an example of an app which has this, and
> explain how to use it (what keys etc.)

Evolution is the GNOME e-mail client.  When you run it, it offers an e-mail interface similar to what you see with Thunderbird.  When focus is in the message summary list, you press the up/down arrow keys to go line by line.  There are many cells on a line: thread status, attachment status, read/unread, from, subject, date, etc.  When you press the left and right arrows, focus switches between the cells on the line and Orca can read each cell.



Blocks: orca
Whiteboard: orca:normal
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
Blocks: caretnav
I don't think anyone is going to work on this given the plan to remove the XUL "tree" widget (bug 1446335).
Status: NEW → RESOLVED
Closed: 14 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.