"uncolored" tags inherit colors from other tags

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: flaimo, Assigned: Karsten Düsterloh)

Tracking

({fixed-seamonkey1.1.1, verified1.8.1.3})

Trunk
fixed-seamonkey1.1.1, verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: thunderbird 2.0 beta 2

seems like there is a little problem when displaying the colors of tags in the dropdown menu (and also in the list in the options-dialog). if you create tags WITHOUT a color information and then tags WITH a color information, the tags without the color inherit the color from the later tag.





Reproducible: Always

Steps to Reproduce:
1) click the "tag" button and then "new tag…"
2) name the new tag "X" and DON'T choose a color. click "OK"
3) create another tag "Y", again without choosing a color
4) create another tag "Z", but this time choose a color
5) click the "tag" button again. "X" and "Y" inherit the color choosen for "Z"
Actual Results:  
see step 5) if you choose red as a color for "Z", then "X" and "Y" also become red.

Expected Results:  
when not choosing a color, the defaulttextcolor should be black, but not take the color information from an unrelated tag.

Comment 1

11 years ago
->NEW on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070127 Thunderbird/2.0pre ID:2007012703
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0
(Assignee)

Comment 2

10 years ago
This is a regression of bug 354726, where the error code for GetColorForKey was dropped.
Assignee: mscott → mnyromyr
(Assignee)

Updated

10 years ago
Assignee: mnyromyr → nobody
Component: General → MailNews: Backend
Product: Thunderbird → Core
QA Contact: general → backend
Version: 2.0 → Trunk
(Assignee)

Updated

10 years ago
Assignee: nobody → mnyromyr
(Assignee)

Comment 3

10 years ago
Created attachment 255452 [details] [diff] [review]
set default colour to be empty

GetColorForKey doesn't do anything wrt the result in the error case, so we can safely empty the string before looking for colours.
Attachment #255452 - Flags: superreview?(bienvenu)
Attachment #255452 - Flags: review?(bienvenu)

Updated

10 years ago
Attachment #255452 - Flags: superreview?(bienvenu)
Attachment #255452 - Flags: superreview+
Attachment #255452 - Flags: review?(bienvenu)
Attachment #255452 - Flags: review+

Comment 4

10 years ago
Comment on attachment 255452 [details] [diff] [review]
set default colour to be empty

Karsten, can you land this on the branch too?
Attachment #255452 - Flags: approval-thunderbird2+
(Assignee)

Comment 5

10 years ago
Landed on trunk and MOZILLA_1_8_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
I included this fix in the SeaMonkey 1.1.1 release tag.
Keywords: fixed-seamonkey1.1.1

Comment 7

10 years ago
adding the fixed1.8.1.3 keyword since karsten kindly landed this on the mozilla 1.8 branch.
Keywords: fixed1.8.1.3
verified on the 1.8 branch using Win XP. I verified using the Tbird candidate build, version 2.0.0.0 (20070326). I was not able to reproduce using the original STR. Adding verified keyword for the branch.
Keywords: fixed1.8.1.3 → verified1.8.1.3
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.