Closed Bug 368490 Opened 13 years ago Closed 13 years ago

ics import does not recognize exeptions of recurring events

Categories

(Calendar :: Provider: ICS/WebDAV, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Sunbird 0.5

People

(Reporter: sebo.moz, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Exeptions of recurring events are not roundtripped in the ics provider. Import of ics files also failes. Regression range:

20070110 works
20070111 fails

bug 364841 seems to have caused this.

STR:
1. subscribe to ics file
2. create recurring event (every 2 weeks, 5 times)
3. modify one occurrence (via drag and drop)
4. restart application

Result: modification is forgotten.

exp. result: roundtrip modifications of recurring events.

Note: export of calendar after modification looks good. The same error happens on import of file.
Flags: blocking-calendar0.5?
while Stefan is right and the problem is known in Bug 364388 Comment #4, I will attach a patch here because the description here fits better to the problem and is outdated in bug 364388.

There was a copy paste error in the if else block, leading to the ignorance of items with a recurrenceID.
Attachment #253107 - Flags: second-review?
Attachment #253107 - Flags: first-review?(ctalbert.moz)
Attachment #253107 - Flags: second-review? → second-review?(mvl)
Comment on attachment 253107 [details] [diff] [review]
copy paste error in if else block

r2=mvl
Attachment #253107 - Flags: second-review?(mvl) → second-review+
Attachment #253107 - Flags: first-review?(ctalbert.moz) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
The patch has been checked in. Removing blocking request.
Flags: blocking-calendar0.5?
You need to log in before you can comment on or make changes to this bug.