Closed Bug 36870 Opened 25 years ago Closed 21 years ago

Can't put entity refs into nodes

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 9850
Future

People

(Reporter: david, Unassigned)

References

()

Details

(Keywords: dom2)

If you create a text node with the contents "español", the entity
reference is not expanded when you dynamically place it into a document.
[That's e-s-p-ampersand-ntilde-semicolon-o-l above, in case Bugzilla _does_
expand the reference.

The test URL shows three attempts to do it; the last two (using CDATASection and
EntityReference) give "not supported" errors in the JavaScript console.
Neither createTextNode nor (and especially not) createCDATASection should expand

entity references. The DOM spec days HTML DOM implemetations don't need to

support createEntityReference() but IMO we should support that, if we don't it's

impossible to dynamically create entity references.

Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug has been marked "future" because the original netscape engineer working

on this is over-burdened. If you feel this is an error, that you or another

known resource will be working on this bug,or if it blocks your work in some way

-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future
Status: NEW → ASSIGNED
Keywords: dom2
Component: DOM Level 2 → DOM HTML
Mass-reassigning bugs.
Assignee: jst → dom_bugs
Status: ASSIGNED → NEW
We already have a bug on createEntityReference

*** This bug has been marked as a duplicate of 9850 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Component: DOM: HTML → DOM: Core & HTML
QA Contact: vidur → general
You need to log in before you can comment on or make changes to this bug.