Last Comment Bug 9850 - {dom1}createEntityReference returning null
: {dom1}createEntityReference returning null
Status: RESOLVED WONTFIX
[nsbeta3-][rtm-]
: dom1
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: P2 normal with 7 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
http://dbaron.org/dom/test/one-core-x...
: 36870 41286 (view as bug list)
Depends on: 15118 611983
Blocks: 125665 256021
  Show dependency treegraph
 
Reported: 1999-07-14 11:19 PDT by David Baron :dbaron: ⌚️UTC-8
Modified: 2014-04-26 03:11 PDT (History)
24 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image David Baron :dbaron: ⌚️UTC-8 1999-07-14 11:19:48 PDT
document.createEntityReference is returning null in an XML document.  It should
be supported.

Observed: Running the above test case gives one error message:
"TEST(S) OMITTED: entref is null."

Expected: Test runs to end.
Comment 1 User image Mike Shaver (:shaver -- probably not reading bugmail closely) 1999-09-16 11:07:59 PDT
Do we need this for beta?
Comment 2 User image Mike Shaver (:shaver -- probably not reading bugmail closely) 1999-09-17 16:22:59 PDT
HTML DOM bugs are M11/P2 for Vidur.
Comment 3 User image ekrock's old account (dead) 1999-11-02 17:46:59 PST
Moving to M14.
Comment 4 User image vidur (gone) 1999-11-04 14:18:59 PST
Handing this one to Nisheeth pending a decision what to do with entity
references and expat.
Comment 5 User image Nisheeth Ranjan 1999-12-21 14:38:59 PST
Bulk moving all M14 non-beta stopper bugs to M17...
Comment 6 User image Nisheeth Ranjan 2000-04-04 14:33:04 PDT
Moving bugs out by one milestone...
Comment 7 User image Nisheeth Ranjan 2000-04-12 23:06:53 PDT
Move back into M17...
Comment 8 User image Nisheeth Ranjan 2000-04-13 14:14:04 PDT
I meant move back into M16...
Comment 9 User image Nisheeth Ranjan 2000-04-21 16:22:19 PDT
Johnny, regardless of whether we decide to pass up entity refernces in expat, 
document.createEntityReference() needs to be implemented so that entitities 
defined in the internal subset of an XML document can be created through the 
DOM.

Should I re-assign this bug to you?
Comment 10 User image Johnny Stenback (:jst, jst@mozilla.com) 2000-04-21 18:15:31 PDT
Are we (in the content sink) given a list of entities defined in the internal
subset? If we are, then supporting creation of references to text (without
markup) or character entities defined in the internal subset (or external subset
for that matter, as long as we're given a list or the defined entities) is
trivial, but supporting creation of references to entities that contain markup
is not as easy, we need to get the DOM tree (ie parse the replacement text) for
the content in the entity we're referensing, same goes for external entities,
but that's even harder since the external file might need to be parsed,
preferably synchronously, and that's not something we can easily do right now
in mozilla AFAIK.

To have a general and clean sollution for this bug I think we need to have bug
15119 (script way of loading XML...), if we had this we could simply use that
service to always parse the entity replacement text, or we could use that
service to load the external file that the entity points to.

What are the plans for bug 15119, do you have any plans for that? Once that is
fixed I'd be glad to take over this bug :)
Comment 11 User image Nisheeth Ranjan 2000-05-03 20:04:14 PDT
Hi Johnny,

I'm passing this to you for now.  Bug 15119 is fixed but you also need:

a) bug 15118 fixed, and
b) a way to generate a DOM from a string

before you can implement this.  I'll try to work on a) and b) next...
Comment 12 User image Mike 2000-06-21 13:40:23 PDT
M16 has been out for a while now, these bugs target milestones need to be 
updated.
Comment 13 User image Johnny Stenback (:jst, jst@mozilla.com) 2000-06-23 16:26:57 PDT
Nominating this for nsbeta3.
Comment 14 User image ekrock's old account (dead) 2000-07-20 10:46:06 PDT
correctness of DOM1 implementation.
Comment 15 User image Nisheeth Ranjan 2000-08-10 07:23:34 PDT
Marking nsbeta3- for now...
Comment 16 User image Jan Carpenter 2000-09-12 12:10:00 PDT
Mass update of qa contact
Comment 17 User image Jan Carpenter 2000-10-06 14:52:43 PDT
Nominating for rtm
Comment 18 User image Nisheeth Ranjan 2000-10-10 13:41:11 PDT
We will not be able to implement this functionality until post Netscape 6.0.
Marking rtm- and futuring.
Comment 19 User image Prashant Desale 2001-03-06 16:23:04 PST
QA contact Update
Comment 20 User image Prashant Desale 2001-06-05 12:06:03 PDT
Updating QA contact to Shivakiran Tummala.
Comment 21 User image Sivakiran Tummala 2002-02-06 21:29:53 PST
nominating for nsbeta1, the main purpose of this method is defeated. I think 
this missed major milestones.
Comment 22 User image Johnny Stenback (:jst, jst@mozilla.com) 2003-03-23 13:09:46 PST
Mass-reassigning bugs to dom_bugs@netscape.com
Comment 23 User image Arunan Balasubramaniam 2003-09-16 02:16:52 PDT
The test URL
(http://www.fas.harvard.edu/~dbaron/dom/test/one-core-xml/EntityReference) is no
longer valid.
Comment 24 User image Boris Zbarsky [:bz] (still a bit busy) 2004-02-13 17:53:34 PST
*** Bug 41286 has been marked as a duplicate of this bug. ***
Comment 25 User image Boris Zbarsky [:bz] (still a bit busy) 2004-04-04 20:33:40 PDT
*** Bug 36870 has been marked as a duplicate of this bug. ***
Comment 26 User image Alan Thomas 2010-12-24 00:59:33 PST
11 years later, document.createEntityReference is still poorly supported by other browsers. IE9 (so far) and Opera don't even implement it. Chrome tries hard, but its implementation is broken.
Comment 27 User image Nochum Sossonko [:Natch] 2010-12-24 07:28:43 PST
Removing helpwanted since this is being removed in bug 611983. This won't make 2.0 afaict.
Comment 28 User image :Ms2ger (⌚ UTC+1/+2) 2011-05-29 07:08:17 PDT
Removed support altogether.

Note You need to log in before you can comment on or make changes to this bug.