Closed Bug 368718 Opened 13 years ago Closed 13 years ago

Essential files for Sunbird startup missing after full AUS update

Categories

(Calendar :: Sunbird Only, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: mattwillis)

References

Details

Attachments

(2 files)

Attached file full update.log file
After doing a full AUs update from Calendar/0.4a1 (20070126) to Calendar/0.4a1 (20070130) Sunbird doesn't start up. Instead an error message is displayed about missing file 'xpcom_compat.dll'.

The reason seems to be that the updater first adds the new 'xpcom_compat.dll' but removes it afterwards because it's listed in /calendar/installer/removed-files.in. Other files might be affected too.
Duplicate of this bug: 369204
puts xpcom_compat inside an ifdef and removes the duplicate entry for it
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #253890 - Flags: second-review?(mvl)
Attachment #253890 - Flags: first-review?(ssitter)
Attachment #253890 - Flags: first-review?(ssitter) → first-review+
Comment on attachment 253890 [details] [diff] [review]
puts xpcom_compat inside an ifdef

r2=mvl
Attachment #253890 - Flags: second-review?(mvl) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with Sunbird 0.4a1 2007021203
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.