Revisit architecture to upgrade timezone ids on the fly

RESOLVED DUPLICATE of bug 363191

Status

Calendar
Internal Components
RESOLVED DUPLICATE of bug 363191
11 years ago
10 years ago

People

(Reporter: Matthew (lilmatt) Willis, Unassigned)

Tracking

Sunbird 0.3

Details

(Reporter)

Description

11 years ago
In bug 368121, mvl wrote the following:

>>Index: calendar/base/src/calDateTime.h
>> class calDateTime : public calIDateTime,
>>                     public nsIXPCScriptable
>>-    nsCString mTimezone;
>>+    calTzId mTimezone;
>Why-oh-why is this a new class. What was wrong with the normal string?

We subclassed the string so that we could easily hook into mTimezone.Assign() and do a check for tzid "freshness" there.

This bug is to allow for revisiting that decision for 0.5 and future releases.
(Reporter)

Comment 1

11 years ago
Not going to make the 0.5 train.
Target Milestone: Sunbird 0.5 → ---
Clint, has there been any change in the way timezones work in the latest 0.8pre nightlies, or if the future outlook has changed?

Comment 3

10 years ago
The mentioned code doesn't exist anymore in this form. We will keep care of updating timezones (and ids) with bug 363191.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363191
You need to log in before you can comment on or make changes to this bug.