Last Comment Bug 369009 - new profile with MCD still pops up new account wizard
: new profile with MCD still pops up new account wizard
Status: RESOLVED FIXED
: fixed1.8.1.2
Product: Thunderbird
Classification: Client Software
Component: Account Manager (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: David :Bienvenu
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 13:52 PST by David :Bienvenu
Modified: 2008-04-03 14:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix - make sure no accounts are already set up (874 bytes, patch)
2007-02-01 13:52 PST, David :Bienvenu
mscott: superreview+
caillon: approval1.8.0.next+
Details | Diff | Splinter Review

Description David :Bienvenu 2007-02-01 13:52:31 PST
Created attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

Even if MCD sets up an account on launch w/ a new profile, we still pop up the account wizard. This is because I forgot to land a fix from the 1.0 branch onto the trunk or 2.0 (the trunk code line's last change date was from before the branch change). Patch upcoming
Comment 1 David :Bienvenu 2007-02-01 14:34:23 PST
fixed on trunk and branch.
Comment 2 David :Bienvenu 2007-04-16 11:09:00 PDT
*** Bug 353838 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Aillon (sabbatical, not receiving bugmail) 2007-06-05 11:36:07 PDT
Comment on attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

This fix is in 1.0, 2.0, and trunk but not 1.5.  One of our major customers is asking for this fix.  I'd like to get this into the next iteration of thunderbird 1.5.  Its rather low risk and we've had tons of testing in various branches.
Comment 4 David :Bienvenu 2007-06-05 11:39:06 PDT
Comment on attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

I agree with Christopher that having a 1.5 build with this fix would be good.
Comment 5 Daniel Veditz [:dveditz] 2007-08-09 11:08:55 PDT
Comment on attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

clearing approval request, fixed keyword says it's already landed on the 1.8.0 branch
Comment 6 Christopher Aillon (sabbatical, not receiving bugmail) 2007-10-26 18:00:51 PDT
(In reply to comment #5)
> (From update of attachment 253666 [details] [diff] [review])
> clearing approval request, fixed keyword says it's already landed on the 1.8.0
> branch


Wrong branch.  1.8.1.x != 1.8.0.x.  This is getting to be a thorn as it's being requested by a few customers.
Comment 7 Christopher Aillon (sabbatical, not receiving bugmail) 2007-10-26 18:01:36 PDT
Comment on attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

re-requesting approval
Comment 8 Christopher Aillon (sabbatical, not receiving bugmail) 2008-04-03 14:00:18 PDT
Comment on attachment 253666 [details] [diff] [review]
proposed fix - make sure no accounts are already set up

a=caillon for 1.8.0.15

Note You need to log in before you can comment on or make changes to this bug.