Closed Bug 369283 Opened 13 years ago Closed 11 years ago

Thunderbird should support the Vista Search

Categories

(Thunderbird :: General, enhancement)

x86
Windows Vista
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: u49640, Unassigned)

References

(Blocks 1 open bug, )

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 

like Bug 290057, but for Vista.

Thunderbird emails should be searchable from the Vista Search function.

(i havent found any bugs concerning this, but i never find anything with the bugzilla search function)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
OS: Windows NT → Windows Vista
this would also work on the "Windows Desktop Search" on WinXP, if I understand this correctly: http://blogs.msdn.com/cheller/archive/2006/06/21/642220.aspx
Status: UNCONFIRMED → NEW
Ever confirmed: true
While searching for information on how to do this, I found this blog post with useful information;

http://slader.vghost.ru/?page_id=10

I believe that this MSDN page may also be helpful,

http://msdn2.microsoft.com/en-us/library/ms692577.aspx
we've got a google soc student whose going to work on this too. We should merge this bug and the excellent information  Rob and Andrew provided with the SoC bug.
Blocks: 377249
Another thing that seems like a good idea is actually cc:ing him on the bug :)
Flags: wanted-thunderbird3?
Flags: wanted-thunderbird3.0a1?
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3.0a1?
This might block Thunderbird3; I'm not sure yet.  It'll depend on how other parts of our search story progress, I think...
Flags: wanted-thunderbird3?
Flags: wanted-thunderbird3.0a1?
Flags: blocking-thunderbird3.0a1?
Flags: blocking-thunderbird3.0a1-
Should this be duped in favour of bug 430614, the bug for GSoC 2008?
Nope, no more than it should have been duped to the previous SoC bug, and no more than that SoC bug should be duped to the new one: I've got complete faith in sid0 getting it done, but this bug is about having it, no matter who does it and when, and his bug is about him doing it this summer.
No longer blocks: 377249
Depends on: 377249, 430614
We need this.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Once this is implemented is there a way to disable this feature.

I dont like the idea of giving any application/OS the power to search my mails.
If I want to search my mail I will (or know to)  search by opening mail client.
Assignee: mscott → nobody
Given where sid0's bug (430614) is at, I think this bug can be duped to it (the functionality is in the tree, and there is basic UI -- there's some UI work pending, but I think this bug should be closed.  Phil, you agree?
Yep, fixed by bug 430614. (Heh, comment 8 sounds like I thought sid0 was going to leave us after SoC; now if he wants to, he's going to have to walk away dragging us all along, as we hang onto his legs and whimper.)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Blocks: TB2SM
You need to log in before you can comment on or make changes to this bug.