Closed Bug 369579 Opened 18 years ago Closed 18 years ago

fixed fonts not honored. spacing not followed

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 314213

People

(Reporter: subscribermail, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: version 1.5.0.9 (20061207)

It seems that even though I use plain text to compose and reply to
images, the mails which I compose, especially when replying to other
messages, do not have correct spacing once the mail is sent.

I posted a screenshot to the issue so this could better be
understood.  I've tried removing all sorts of auto-formatting in
Thunderbird but I still get to see this issue.

http://202.78.123.20/thunderbird/index.html

Reproducible: Always

Steps to Reproduce:
1. Configure TB such that it uses fixed size fonts and never uses HTML mail.
2. Write the following mail and address it to yourself:

This is an email that was composed in a fixed size font.
Here's another line
and one more line.
And another line.  Note that this mail is made up of several lines using fixed width fonts.


2.  Hit Send (wait until you receive it)
3.  Once you receive your own mail, click reply

(Here, I noticed the difference in fonts and spacings between the original mail and the received mail)

4.  Reply to your own mail (i.e. recursive reply), putting a reply text in between one of the lines in the original mail, and one line of text after the whole inlined message

(Here, the two lines are of different fonts.)
Actual Results:  
Here: 
http://202.78.123.20/thunderbird/index.html

Expected Results:  
There should be no change in fonts and the line spacings must be honored.

There should be no change in fonts and the line spacings must be honored.
http://kb.mozillazine.org/Plain_text_e-mail_(Thunderbird)

Fonts are not supported in plain text email. I guess your allowed to select the font you're most comfortable writing things in, as an aid to composition, but that doesn't affect what is sent. (I don't have thunderbird, but in seamonkey, in the preferences, you can choose whether to display plain text mail in fixed or variable width font, and choose a color and size to display what appear to be quotes.)

That leaves line break and spacing issues. Try saving the email you received, and opening it in a text editor. Check to see if the spacing & line break issues are one of display, or whether the spaces where eliminated before sending.
> It seems that even though I use plain text to compose and reply to
> images, the mails which I compose, especially when replying to other
> messages, do not have correct spacing once the mail is sent.

Carlo, you're using the HTML compose window, and the font you're using is proportional, not fixed.  If you want your composition to look like the outgoing plain text message, you should be using the plain text compose window.  (This is set under Account Settings, Composition&Addressing.)

Be aware that even with plain text, there can be differences in what's in the editor and what gets seen; lots of people who feel strongly about their mail formatting end up turning off format=flowed support.  (See bug 168420 and the informative FAQ attached to that bug.)

Also, the "font width" is not necessarily going to be honored by the client that receives it; Thunderbird, for one, allows a proportional font to be used for plain-text messages.


The problem of separation between paragraphs when composing HTML and sending plain is known, so I'm duping this bug to that.  The real issue there is that the margins on the blockquote are set much larger than necessary, so in the compose window there appears to be an entire additional blank line between text.  

My comment at bug 307112 comment 10 provides a workaround to override those margins, so that if you continue to compose with the HTML editor, the spacing you see will more closely resembled the plain-text version that's sent out.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
(In reply to comment #1)
> http://kb.mozillazine.org/Plain_text_e-mail_(Thunderbird)
> 
> Fonts are not supported in plain text email. I guess your allowed to select the
> font you're most comfortable writing things in, as an aid to composition, but
> that doesn't affect what is sent.

That's right.  Just for our info, I actually do not even select a font (since I simply want to use plain text).  Selecting fonts would probably make Thunderbird think that I'm writing HTML mail.  So, I never really explicitly selected any fonts at all.

> That leaves line break and spacing issues. Try saving the email you received,
> and opening it in a text editor. Check to see if the spacing & line break
> issues are one of display, or whether the spaces where eliminated before
> sending.

Thank you for the pointers!  I'll surely do that.  
(In reply to comment #2)
> > It seems that even though I use plain text to compose and reply to
> > images, the mails which I compose, especially when replying to other
> > messages, do not have correct spacing once the mail is sent.
> 
> Carlo, you're using the HTML compose window, and the font you're using is
> proportional, not fixed.  If you want your composition to look like the
> outgoing plain text message, you should be using the plain text compose window.
>  (This is set under Account Settings, Composition&Addressing.)

Thanks for these pointers Mike.  This "plain text compose window" is something that made my day. For some reason, I never actually cared to look at "Composition & Addressing" since I think all font issues are resolved under "Options->Content->Fonts & Colors".   
> 
> Be aware that even with plain text, there can be differences in what's in the
> editor and what gets seen; lots of people who feel strongly about their mail
> formatting end up turning off format=flowed support.  (See bug 168420 and the
> informative FAQ attached to that bug.)
> 
> Also, the "font width" is not necessarily going to be honored by the client
> that receives it; Thunderbird, for one, allows a proportional font to be used
> for plain-text messages.

I think that's fine.  What is more important, I guess, are the line breaks.  Having proper line breaks makes it hard for the reader to really miss reading anything in the mail.   As I'm sure we're all aware, interleaved texts that do not have proper line breaks are very difficult to read and follow. 

> My comment at bug 307112 comment 10 provides a workaround to override those
> margins, so that if you continue to compose with the HTML editor, the spacing
> you see will more closely resembled the plain-text version that's sent out.
> 
> *** This bug has been marked as a duplicate of bug 314213 ***

No prob.  Still, Thunderbird rocks.  You guys rock.  Thanks for the good work. 

(In reply to comment #4)
> Thanks for these pointers Mike.  This "plain text compose window" is something
> that made my day. For some reason, I never actually cared to look at
> "Composition & Addressing" since I think all font issues are resolved under
> "Options->Content->Fonts & Colors".   

Great.  Be aware that the compose-as-HTML setting is identity-specific -- if you create alternate identities within an account, or multiple accounts, you have to make sure you've got the setting correct for each one.

I believe that if you set the preference   mail.identity.default.compose_html   to false (it's normally true), then each new identity will default to using plain text.
(In reply to comment #5)
> (In reply to comment #4)
> > Thanks for these pointers Mike.  This "plain text compose window" is something
> > that made my day. For some reason, I never actually cared to look at
> > "Composition & Addressing" since I think all font issues are resolved under
> > "Options->Content->Fonts & Colors".   
> 
> Great.  Be aware that the compose-as-HTML setting is identity-specific -- if
> you create alternate identities within an account, or multiple accounts, you
> have to make sure you've got the setting correct for each one.
> 
> I believe that if you set the preference   mail.identity.default.compose_html  
> to false (it's normally true), then each new identity will default to using
> plain text.

Wow!  Even better. This is exactly what I was looking for.  Thanks!

You need to log in before you can comment on or make changes to this bug.