Closed Bug 36961 Opened 20 years ago Closed 20 years ago

using menubuttons hikes tinderbox leaks by 100 times

Categories

(Core :: XUL, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 37639

People

(Reporter: radha, Assigned: waterson)

References

()

Details

Attachments

(2 files)

Changing back/Forward buttons to use menubuttons instead of buttons increased
the leak count in tinderbox tremendously.

To try, change the back/forward button definitions in navigator.xul to

<menubutton id="back-button" ......>
<menupopup>
</menupopup>
</menubutton>
can you post some diffs, and I'll take a look? thanks...
radha: put diffs in the bug and reassign back to me.
Assignee: waterson → radha
chris,  Please see the diffs for navigatorOverlay and navigator.xul. The diffs
simply enable a commented out <menubutton> code and a corresponding small change
to the observers. sfraser who did ran leaky when tinderbox showed the leaks,
mailed out the following details. Hope this helps.

Leaks went up from 7K to 746K between about 4pm and 5pm today; the log shows
that the new leaks are:
nsCSSSelector 44448 138800.00%
nsCSSRule 14256 89000.00%
CSSDeclarationImpl 61560 80900.00%
nsEventListenerManager 22608 31300.00%
nsVoidArray 29856 15450.00%
nsSupportsArray 14480 11966.67%
nsClassList 1800 7400.00%
nsStr 80960 4348.35%
HTMLAttribute 1040 2066.67%
NameSpaceManagerImpl 216 1700.00%
nsStdURL 164 1266.67%
nsTextNode 420 600.00%
HTMLAttributesImpl 960 433.33%
nsNoAuthURLParser 48 300.00%
nsXPCWrappedNativeScope 112 300.00%
nsXPCWrappedNative 192 300.00%
nsXPCComponents 192 300.00%
nsThread 72 200.00%
XMLElementFactoryImpl 24 100.00%
nsHTMLMappedAttributes 112 100.00%
 nsThreadPoolRunnable 32 100.00%
nsXPCWrappedNativeClass 96 100.00%
 nsThreadPool 72 100.00%
nsGenericFactory 60 50.00%
nsLocalFile 1392 33.33%
xptiInterfaceInfo 288 14.29%

Assignee: radha → waterson

*** This bug has been marked as a duplicate of 37639 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.