Closed Bug 8241 Opened 21 years ago Closed 20 years ago

[FEATURE] Session history in Back & Forward buttons

Categories

(Core :: DOM: Navigation, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: radha, Assigned: radha)

References

()

Details

QA Contact: leger → claudius
Updating QA Contact for us to verify for ya when implemented.
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Blocks: 10575
Depends on: 11601
Target Milestone: M9 → M10
I have most of my code ready. For actually hooking up, I need 11601 to be fixed.
Marking this dependant on 11601 and moving to M10.
Component: other → XPApps
Summary: [FEATURE]Hook up session History to Back & Forward buttons → [FEATURE] Session history in Back & Forward buttons
Whiteboard: Radha has most of her code ready ...
Whiteboard: Radha has most of her code ready ... → Radha has most of her code ready
Whiteboard: Radha has most of her code ready → Waiting for 11601 to be fixed
Blocks: 12651
Target Milestone: M11 → M15
I hear this is not dogfood. Moving to M15
No longer blocks: 10575
No longer blocks: 12651
*** Bug 23842 has been marked as a duplicate of this bug. ***
Whiteboard: Waiting for 11601 to be fixed
[Clearing status -- bug 11601 has been fixed. Adding self to CC list.]
How are you planning to implement this? I've voluntered to make menubuttons for 
mail. To test this I've created menubuttons for back and forward too. It 
updates the menus onmousedown from the appCore.SessionHistory.

Maybe we should synchronize our solutions.
Although being the older bug, I think this is a duplicate of bug 16806.
Please have a look there and mark as duplicate if appropriate.
I don't think these are duplicates at all. THis bug is about having drop down menus in the Back and Forward buttons, whereas the 
other is about rememberingthe Y- cordinate of the view when you go back to a page. Other than they both use session history 
they are differnet bugs.
Radha is on sabbatical by the way in case anyone was wondering.
Component: XPApps → History
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
*** Bug 32076 has been marked as a duplicate of this bug. ***
Target Milestone: M15 → M16
*** Bug 34756 has been marked as a duplicate of this bug. ***
In case people are interested, there's an overlay that does this at
http://www.mozillazine.org/chromezone/
*** Bug 35939 has been marked as a duplicate of this bug. ***
Is there any plans to add the overlay that's listed in Chromezone to the tree? I
think having some sort of back/forward session history should be enabled by
default in Mozilla as soon as possible.

Although I'd really like to see session history implemented like in Netscape 4.x
where you hold down the button for a few seconds to get the menu up.

There should also be a little down arrow next to these buttons (as in 4.x and
IE) so people know that these buttons can bring up a menu.
Depends on: 36961
Depends on: 37639
Bug 36961, a dependency of this one, was closed as a dup of bug 37639. Adding 
37639 as a dependency.
Checked in code to enable back/forward menus
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Marking VERIFIED. there are bugs but the feature is there.
Status: RESOLVED → VERIFIED
*** Bug 31404 has been marked as a duplicate of this bug. ***
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.