Closed Bug 369855 Opened 14 years ago Closed 3 years ago

Can't move caret into floats using up/down arrow keys

Categories

(Core :: DOM: Selection, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: uriber, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase, Whiteboard: orca:urgent)

Attachments

(1 file)

In caret browsing mode:
- Go to http://www.mozilla.org/about/
- Place the caret somewhere in the footer.
- Try using up-arrow to move into the main content.
- Notice that the page scrolls all the way to the top, and the caret disappears.

This is because the main content portion of the page is a float.
First reported by Willie Walker in bug 205846 comment 9 (step #4).

The attached testcase shows that the problem exists in both directions (you can't enter a float using down-arrow either. In both cases, the caret skips the float.
Additionally, placing the caret on the first line of the float (e.g. using the mouse), and then pressing up-arrow, moves the caret to the row before the one preceding the float.

Bug 334626 (fixed) was about a similar problem for left/right arrows.
Attached file testcase
Blocks: caretnav
Blocks: orca
Whiteboard: orca:urgent
Flags: blocking1.9?
Not a blocker since this isn't a regression
Flags: blocking1.9? → blocking1.9-
Hi Uri, Ginn: any ideas on this bug and why it is so difficult to fix?  Are there any workarounds that can be done in Orca or Gecko for this?
Assignee: selection → nobody
QA Contact: selection
Dear all,

Is anybody still able to reproduce this bug ?

In a test on Firefox Nightly on Debian GNU/Linux 8.8 with Orca 3.24 I can't reproduce the issue with the attached testcase.

Best regards.
Flags: needinfo?(mzehe)
Flags: needinfo?(jdiggs)
Not relevant on Windows, since we don't use Caret Browsing with screen readers, and I cannot visually verify this bug. Leaving the NI for Joanie to look at it from the Orca perspective.
Flags: needinfo?(mzehe)
Closing as WONTFIX. Orca does its own caret navigation.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jdiggs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.