Edit/Delete action from calendar context menu are only correct for events not tasks

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
--
trivial
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Tonin, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061115 Mandriva/2.0.0.1-4mdv2007.0 (2007.0) Firefox/2.0.0.1
Build Identifier: 2007020821

Is a task an event ? In french I would say no.
With the mouse over a task in the calendar context menu, it is written "Modifier l'évènement sélectionné" - "Supprimer l'évènement sélectionné..."
"évènement" fits to event but not to task ("tâche" in french)
'la tâche' should replace 'l'évènement' when the mouse is over a task.
If it is not possible to have different context menus for both a task and an event, the solution would be to consider event and task as a whole, a element.
Then the localization will be "Modifier l'élément sélectionné", "supprimer l'élément sélectionné"

Reproducible: Always

Actual Results:
In Lightning tasks and event have "Edit/Delete Item" in their context menu. In Sunbird we have always "Edit/Delete selected Event" in the context menu for the views. The task list has correctly "Edit/Delete Task" in the context menu.

Confirmed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070226 Calendar/0.5pre.
Severity: enhancement → trivial
Status: UNCONFIRMED → NEW
Component: Calendar Views → Sunbird Only
Ever confirmed: true
OS: Linux → All
QA Contact: views → sunbird
Hardware: PC → All
Summary: modify and delete action from calendar context menu are ok for event and wrong for task → Edit/Delete action from calendar context menu are only correct for events not tasks
I assume that the context menu is context sensitive. Therefore it makes no sense to duplicate the information about event/task into the context menu. 
So the menu item should be just 'Edit' or 'Delete' in my opinion.

See Bug 374464 for a similar issue with Lightning.
Duplicate of this bug: 399343
Depends on: 340025
After the checkin for Bug 430430 this issue doesn't exist anymore. Sunbird now uses the dreadful Edit Item / Delete Item from Lightning (see Bug 374464).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 340025
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.