Cycling through tabindex among HTML inputs only works once

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

(Blocks: 1 bug, {access, testcase})

Trunk
access, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

543 bytes, application/xhtml+xml
Details
(Reporter)

Description

11 years ago
Created attachment 254707 [details]
testcase

I discovered this while testing a fix for bug 306058.

Steps to reproduce:
(1) Tab all the way through the document.
(2) Tab past the URL bar and search bar in the main window.
(3) Tab until you land in another HTML input.

Expected results:
You should land in the third HTML input (index 1).

Actual results:
You land in the first HTML input (no index).

requresting blocking1.9: This is actually an accessibility issue, because the next tab doesn't take you to another HTML input - but instead out of the document altogether.
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
also seen on Mac trunk build.  OS, Platform -> All.
OS: Windows XP → All
Hardware: PC → All

Updated

11 years ago
Blocks: 83552
If I click the document with the mouse, then focus the URL bar with Control+L and go tabbing through the document, it jumps the index 1 and follow the rest of the order.
(Reporter)

Comment 3

11 years ago
In nsEventStateManager::GetNextTabbableContent, the stacks are identical; the only difference I can find is that the first time this method gets called, aStartFrame is null and aIgnoreTabIndex is false.  The second time, aStartFrame is not null and aIgnoreTabIndex is true.
Sorry... it depends where you click.
Index 2 is the easier to reach, since the whole area bellow it will activate it.
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
Flags: wanted1.9+
Whiteboard: [wanted-1.9]

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Depends on: 178324
Resolution: --- → FIXED

Comment 5

8 years ago
Fixed by bug 178324.

Comment 6

8 years ago
I can still reproduce with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.5pre) Gecko/20091009 SeaMonkey/2.0pre

Comment 7

8 years ago
(In reply to comment #6)
> I can still reproduce with:
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.5pre) Gecko/20091009
> SeaMonkey/2.0pre

How about a current version or trunk?

Comment 8

8 years ago
Eh, yeah. Sorry. My fault. I thought that that SeaMonkey version was using trunk.
You need to log in before you can comment on or make changes to this bug.