Closed Bug 370425 Opened 13 years ago Closed 13 years ago

Creating repeating event fails, Error 'calRecurrenceRule is not defined' is shown

Categories

(Calendar :: General, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: damian.publicemail, Assigned: jminta)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070214 Calendar/0.4a1

Can not press button OK in Edit Recurrence dialog what means that there is no possibility to create or modify repeating events/tasks

Reproducible: Always

Steps to Reproduce:
1. Double press in main view
2. Select checkbox Repeat and press button Set pattern
3. Press OK in Edit Recurrence dialog

Actual Results:  
no effects, dialog is still opened

Expected Results:  
dialog should be closed

error console:

Error: calRecurrenceRule is not defined
Source File: chrome://calendar/content/calendar-recurrence-dialog.js
Line: 235


looks like regression
Confirmed. Looks like regression from Bug 366560. Mismatch between calRecurrenceRule and CalRecurrenceRule?
http://lxr.mozilla.org/mozilla/search?string=calRecurrenceRule
Blocks: 366560
Keywords: regression
OS: Windows XP → Windows 2000
Summary: can not press OK in Edit Recurrence dialog → Creating repeating event fails, Error 'calRecurrenceRule is not defined' is shown
Attached patch patchSplinter Review
Updates calls to the newer calUtils.js
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #255477 - Flags: second-review?(mvl)
Attachment #255477 - Flags: first-review?(cmtalbert)
Flags: blocking-calendar0.3.1?
Damian,
1. 0.3.1 already shipped. We can't block it anymore :)
2. The bug that caused this wasn't applied to 0.3.1. It's only in the newer builds.
Flags: blocking-calendar0.3.1?
Attachment #255477 - Flags: first-review?(cmtalbert) → first-review?(ctalbert.moz)
Comment on attachment 255477 [details] [diff] [review]
patch

Looks good.  Tested on Lightning Windows w/tbird 2.0.x.
Attachment #255477 - Flags: first-review?(ctalbert.moz) → first-review+
Comment on attachment 255477 [details] [diff] [review]
patch

r2=mvl
Attachment #255477 - Flags: second-review?(mvl) → second-review+
Whiteboard: [needs checkin]
Duplicate of this bug: 372083
Duplicate of this bug: 372308
T-bird 1.5.0.10(20070221)
Problem still there in Lightning V0.5pre (build 2007030205).

Setting repeat does nothing.  Unable to click "OK" to execute routine
Please someone take care to check in this regression fix before next Test Day.
Fix checked in for trunk and MOZILLA_1_8_BRANCH.

--> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3pre) Gecko/20070304 Calendar/0.5pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.