New download URLs make saving extensions difficult

RESOLVED FIXED

Status

defect
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: gaubugzilla, Assigned: sancus)

Tracking

Details

(Reporter)

Description

12 years ago
Go to some extension page, right-click on "Install now" and choose "Save link target as". The suggested file name will be something like 12345.htm - it should be extension_name-version.xpi instead. At the very least it should be done with the Content-Disposition HTTP header.
(Assignee)

Comment 1

12 years ago
Content-disposition has no effect on Save Link As, as far as I can tell, so that's pretty useless. However, we will have a "Download" button in place of the install button for Thunderbird add-ons that will use Content-Disposition attachment, and may add one for non-tb add-ons.

The only way I can see to fix this is by tacking the filename onto the end of the url even if it doesn't mean anything to Remora.
(Assignee)

Updated

12 years ago
Assignee: nobody → sancus
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Yes, the content-disposition header might indeed help: http://us2.php.net/header (search for content-disposition). Doesn't this suggest the right filename for the downloaded file?

However if you choose to implement this, make sure it doesn't break the regular installations. :)
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> Content-disposition has no effect on Save Link As, as far as I can tell, so
> that's pretty useless.

Tested this, you are right.

> The only way I can see to fix this is by tacking the filename onto the end of
> the url even if it doesn't mean anything to Remora.

Exactly.

Comment 4

12 years ago
Re. content disposition headers - Bug 299372

Updated

12 years ago
Duplicate of this bug: 371610
(Assignee)

Comment 6

12 years ago
I added a trailing filename to all the download urls, which should deal with this.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 7

12 years ago
V.FIXED on preview.addons.mozilla.org.
Status: RESOLVED → VERIFIED

Comment 8

12 years ago
I'm still seeing this on http://preview.addons.mozilla.org/en-US/thunderbird/addon/878 (login required)
Looks like the sandbox install needs the filename appended as well.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

12 years ago
It has it appended, and works in the test data. Not really sure what's going on here on preview. Going to have to get the full data dump to debug this.

Comment 11

12 years ago
There is a problem with sanitizing the URLs as well, see bug #372302 which fixed +, but other chars, like ' are being left in.

Ciao!

Comment 12

12 years ago
This doesn't seem to be reproducible anymore, does it ?
(Reporter)

Comment 13

12 years ago
Yes, I think this can be marked fixed again.
So be it, thanks.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.