If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cocoa native buttons draw outside bounds, have incorrect border/padding setup

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

8.97 KB, patch
Stuart Morgan
: review+
Stuart Parmenter
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
Created attachment 255360 [details] [diff] [review]
fix v1.0

cocoa native buttons draw outside bounds, have incorrect border/padding setup
Attachment #255360 - Flags: review?(stuart.morgan)

Comment 1

11 years ago
Comment on attachment 255360 [details] [diff] [review]
fix v1.0

>+  // We assume that all native widgets can draw a focus ring that will less than or
>+  // equal to 4 pixels thick.

s/that will less than/that will be less than/

r=smorgan.
Attachment #255360 - Flags: review?(stuart.morgan) → review+
(Assignee)

Updated

11 years ago
Attachment #255360 - Flags: superreview?(dbaron)
(Assignee)

Updated

11 years ago
Attachment #255360 - Flags: superreview?(dbaron) → superreview?(pavlov)

Updated

11 years ago
Attachment #255360 - Flags: superreview?(pavlov) → superreview+
(Assignee)

Comment 2

11 years ago
fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Depends on: 370769

Updated

11 years ago
Duplicate of this bug: 153572

Updated

10 years ago
Blocks: 387486
You need to log in before you can comment on or make changes to this bug.