Closed Bug 371012 Opened 16 years ago Closed 16 years ago

RFE Print month/week/day view showing all days and all events

Categories

(Calendar :: Printing, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 340195

People

(Reporter: guallar, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061220 Mandriva/1.5.0.9-1mdv2007.0 (2007.0) Firefox/1.5.0.9
Build Identifier: Lightning 0.3.1

this is a Requests for Enhancement (RFE)

There should exist a one-click printing function, that would print the month (or week or day) view, as shown on screen.

For the month view, it would show all days, and each event. For each event, it would show the event's time. Just like the on-screen view.

A way to implement is:
* To print the month view, user displays "month view" on screen, and then user does File>Print / Print Preview, 

* To print the week view, user displays "week view" on screen, and then user does File>Print / Print Preview, 

* To print the day view, user displays "day view" on screen, and then user does File>Print / Print Preview, 

This request for enhancement has arisen b/c all (100%) of my users ask me "how do I print my calendar?".

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Open File  menu
3. Print options (print or Print Preview)
4. Printer should print current view
Actual Results:  
Print/ Print Preview are grayed out, so there is no printing

Expected Results:  
Print current view (month/week/day)
(In reply to comment #0)

> Actual Results:  
> Print/ Print Preview are grayed out, so there is no printing
> 
> Expected Results:  
> Print current view (month/week/day)
> 

Go to Calendar>Print and there you have all options you are asking for. (Monthly Grid, List, and Weekly Planner). The only thing that is not currently implemented is a one click print feature and a day view printout.
(In reply to comment #1)

> Go to Calendar>Print and there you have all options you are asking for.
> (Monthly Grid, List, and Weekly Planner). The only thing that is not currently
> implemented is a one click print feature and a day view printout.

What version of Calendar are you using? 

There is no "Print" option in Lightning's Calendar menu. 

Using Lightning 0.3.1 (latest stable release)


(In reply to comment #2)

> Using Lightning 0.3.1 (latest stable release)
> 
You are right. Using the nightlies I forgot, that this feature is not available in 0.3.1 builds. Sorry about that. Have a look at the current nightlies (bugs to be expected!) or wait until version 0.5 which is scheduled for mid-April.

The original bug for printing in Lighning is bug 340195.

Nominating to resolve this bug as Duplicate.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340195
This bug includes a request to print a day view with all events, that isn't supported yet is it? If so I don't see it in 1.0b7. I see weekly planner and list, but no way to bring single day.
I found the new bug #385887 which specifically request print a day view, so I will follow-up/vote there.
You need to log in before you can comment on or make changes to this bug.