Other message shows up when double clicked, doen't match thread pane, then wrong message quoted in reply

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: elharo, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Googlebot/2.1 (+http://www.googlebot.com/bot.html)
Build Identifier: 1.5.0.9 20061207

Often though not always when I reply to a message the quoted text of one or more other messages in my Inbox is appended to the outgoing message in the compose window. 

Reproducible: Sometimes

Steps to Reproduce:
1. Reply to a message
2. Look at quoted text at bottom of message



This has the potential to accidentally forward e-mail to recipients who weren't meant to get it. That could range from trivial to disastrous.
(Reporter)

Comment 1

12 years ago
OK. Probably related, though it does not involve a compose window or a reply.  In my Inbox I have a message allegedly from Jim Deegan at 4:35 AM, or so the Inbox tells me. When I double click or press return to open it I instead see a message two earlier from Michael Hermann. This has happened multiple times. 

The message I do see has an attachment (an HTML attachment that shows up in plain text when I open Deegan's message.) that seems to come from an intermediate message from Helgason. i.e. the Inbox looks like this:

Hermann
Hermann
Helgason
Deegan

Opening Deegan shows a mix of the first Hermann message and the Helgason message.

All four messages have identical subject lines.


I am filtering to see only unread messages, and have messages sorted by subject. I don't know if that matters or not.

This is IMAP and Inbox is stored on the server,
(Reporter)

Comment 2

12 years ago
With Pine on a separate system I can view Deegan's message. It has an attached file. 

If the IMap Inbox on the server is corrupt, it is not corrupt in such a way as to confuse Pine. The problem only manifests itself with Firefox.

(Reporter)

Comment 3

12 years ago
Quitting and restarting TB does seem to have cleared up this problem with this message. I can now open Deegan's message in TB, which I could not before. 

do you see this starting in safe mode using version 2?
 http://kb.mozillazine.org/Safe_Mode

for additional help http://www.mozilla.org/support/thunderbird/forums
Assignee: dveditz → nobody
Severity: critical → normal
Component: Security → Mail Window Front End
QA Contact: thunderbird → front-end
Version: unspecified → 1.5
(Reporter)

Comment 5

12 years ago
I haven't seen it for a while in any version. I cannot reproduce it on command, I'm afraid. It may well require some very weird combination of events to put TB in a state where this happens. 
Elliotte, what do you mean by "any version"?  Does new summary better describe the problem? If so can you find the bug it matches, because I'm pretty sure one exists making your bug a duplicate?  If not and you no longer see the bug, please close by setting resolution to WORKSFORME.
Summary: Other messages show up in reply → Other message shows up when double clicked, doen't match thread pane, then wrong message quoted in reply
no response, so => WFM - not seeing this in v2 or trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.