Last Comment Bug 371285 - Crash loading form with select inside repeat
: Crash loading form with select inside repeat
Status: RESOLVED FIXED
: fixed1.8.0.12, fixed1.8.1.4
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Olli Pettay [:smaug]
: Stephen Pride
Mentors:
Depends on:
Blocks: 371595
  Show dependency treegraph
 
Reported: 2007-02-22 11:27 PST by aaronr
Modified: 2016-07-15 14:46 PDT (History)
0 users
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (2.12 KB, application/xhtml+xml)
2007-02-22 11:27 PST, aaronr
no flags Details
proposed patch (1.02 KB, patch)
2007-02-24 09:04 PST, Olli Pettay [:smaug]
aaronr: review+
surkov.alexander: review+
Details | Diff | Splinter Review

Description aaronr 2007-02-22 11:27:07 PST
I have a form that crashes on load.  It is supposed to repeat a select control 3 times.  The problem is with the nsXFormsControlList again.  Even though we added the addref logic to the list, we seem to be encountering items on the list that should not be there (they've been freed already).

This is possibly related to bug 371121, but in that case the crash was when doing an insert.
Comment 1 aaronr 2007-02-22 11:27:53 PST
Created attachment 256057 [details]
testcase
Comment 2 Olli Pettay [:smaug] 2007-02-24 09:04:36 PST
Created attachment 256281 [details] [diff] [review]
proposed patch
Comment 3 aaronr 2007-02-24 14:13:39 PST
Comment on attachment 256281 [details] [diff] [review]
proposed patch

The crash is gone, but the testcase still doesn't work correctly (no items show up in the selects).  Please open a bug and attach this testcase for that issue.

with that, r=me
Comment 4 Olli Pettay [:smaug] 2007-02-25 04:09:54 PST
bug 371595 filed, patch checked in.
Comment 5 aaronr 2007-04-23 16:15:00 PDT
checked into 1.8 branch on 2007-04-12
checked into 1.8.0 branch on 2007-04-16

Note You need to log in before you can comment on or make changes to this bug.