cannot open attachments from emails saved as files outside of thunderbird

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Paul Dodd, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Version 2 beta 2 (20070116)

If I open an file which is an email containing an attachment it is opened OK. However if I try to open the attachment by double clicking on it or from the context menu nothing happens. In the error console the following message is shown:
Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMessenger.openAttachment]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/msgHdrViewOverlay.js :: openAttachment :: line 1050"  data: no]

On trying to drag the attachment to e.g. the desktop an error alert is shown with something like "Cannot save attachment. please check the name and try again". The message is shown twice. In the error console the following is shown:
Fehler: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMessenger.saveAttachmentToFolder]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/msgHdrViewOverlay.js :: anonymous :: line 1590"  data: no]
Quelldatei: chrome://messenger/content/msgHdrViewOverlay.js
Zeile: 1590
(also twice).

The problem occurs for mails created in thunderbird 2 beta 2 (e.g. created in drafts), from thunderbird 1.5.09 and outlook express. I tried it with PDF and text attachments, same results.

This was all on a fresh install of thunderbird 2 beta 2.

Reproducible: Always

Steps to Reproduce:
1.Create email in drafts with attachment.
2.Save the email on the desktop.
3.Open the email file in thunderbird.
4.Try to open the attachment.
Actual Results:  
Nothing happened.

Expected Results:  
I expected the attachment to be opened or at least a dialog asking what I wanted to do.

A few addons were installed, but guess that there was no impact. The default theme was used. Changing to another made no difference.
Addons:
Dictionary switcher
Br-eng, De-CH, fr dictionaries
lightening
quicktext
talkback
keyword highlight
(Reporter)

Comment 1

12 years ago
Tried in version 3 alpha 1 (20070223); same results. In error console
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMessenger.openAttachment]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/msgHdrViewOverlay.js :: openAttachment :: line 1056"  data: no]

Comment 2

12 years ago
I can reproduce this on latest branch, but I think it may be a duplicate of bug 203570 (via bug 336650). 
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
Don't agree that it's a duplicate of bug 203570. The email wasn't forwarded or otherwise enclosed in an e-Mail. Naturally the problem miay arise from the same causes but the test case is different.

Comment 4

11 years ago
Or bug 351064.

Comment 5

10 years ago
works here both 2 and 3

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.16) Gecko/20080708 Lightning/0.9pre Thunderbird/2.0.0.16 - Build ID: 2008070808
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.2pre) Gecko/2008072303 Shredder/3.0a2pre ID:2008072303

I think it has been solved as show in bug 372135, probable dupe
If the attachment is .eml though, then is still on and is bug 351064

I'd say is wfm or dup to solved one

Updated

10 years ago
Assignee: mscott → nobody
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0
(Reporter)

Comment 6

10 years ago
Seems to be solved (2.0.0.17 (20080914)).
You need to log in before you can comment on or make changes to this bug.