radio and checkboxes process on mouseup regardless of where mousedown originated

VERIFIED DUPLICATE of bug 35606

Status

()

P3
normal
VERIFIED DUPLICATE of bug 35606
19 years ago
19 years ago

People

(Reporter: bugzilla, Assigned: bugs)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 2000042508

Has this been reported? I couldn't find anything.

Two related mouseup/mousedown problems with checkboxes and radio buttons---

Steps to Reproduce:

(1) Open Preferences (Edit | Preferences)
(2) Choose the "Appearance" category
(3) Hold the left mouse button down over the radio button (under "Show toolbars 
as") that is currenly checked and, with the button still down, move the mouse 
over the text (or the actual button itself) of one of the two other unchecked 
buttons.  Then release the mouse.

Rather than just doing nothing as it should, the button that you release the 
mouse button over becomes checked.  The above is also true among 
checkboxes...in fact, you can even put the mouse down on a checkbox and release 
it over a radio button for the same result (or vice-versa).  

The other problem is that you can actually uncheck one of a group of radio 
buttons (something that shouldn't be allowed).  Repeat the above, but instead 
of moving the mouse over another radio button after you mousedown on the 
currently checked one, move the mouse a little ways to the right until it's 
outside the area of the text that goes with the radio button.  Then release the 
left mouse button--the radio button then becomes unchecked, leaving all of them 
unchecked.

(I know this sounds a bit confusing, but it's really not.  As an example, check 
the "Text Only" box if it isn't already checked.  Then, hold the left mouse 
button down on "Text Only"" and then, with the left mouse button still down, 
move the mouse to the area next to the spot where the text of any of the other 
two radio button ends.  You can either move it to the right of the word "Only" 
in "Pictures Only" or the right of the word "Text" in "Pictures and Text").

I definitely made the above sound waaaay too complicated (sure would suck if 
this was inv or a dup :) - this is far easier than it sounds.

As far as I can tell, this is reproducible in any place containing these 
widgets, although the steps to reproduce sometimes vary slightly.
(Reporter)

Comment 1

19 years ago
argh.  god I feel stupid.  Ignore the whole second part of the report about how 
to uncheck radio buttons.  It can be done much easier than how it was 
explained - simply check a radio button and then click a little bit 
above/below/around it to uncheck it.

The first issue, that putting the mouse down over one widget and releasing it 
over another will check the other widget, still applies though.

Comment 2

19 years ago
If, rather than Preferences>Appearance, this is tried with 
Preferences>Navigator, you can see that the radiou button under the mouseup
not only appears to be checked, but is checked -- just open a new browser
window after changing the "Navigator Starts With" preference.

Also, the drag between the mousedown and mouseup does not need to start
over the already-checked radio button, any-to-any will do.

None of that is reproducible with the "Forms" demo page, Debug>Viewer Demos>#8.
Guessing from that that this is not an "HTML Form Controls" bug, but a 
"Preferences" bug.
Assignee: trudelle → matt
Component: XP Toolkit/Widgets → Preferences
QA Contact: jrgm → sairuh
jrgm, widgets...? is this seen in other dialogs?
QA Contact: sairuh → jrgm

Comment 4

19 years ago
The two bugs in this report may need to be separated.  I am seeing problems with 
radio buttons on Mac.  In particular, I have seen where you can click between two 
radio buttons and the selected one becomes unselected and the other doesn't get 
selected.

Probably this isn't Matt's bug but Ben's or someone elses.
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 5

19 years ago
->XP

This isn't just the prefs dialog.  The exact same checkbox problem occurs in 
the Find on this Page dialog.   I think it's just a generic widget problem.
Component: Preferences → XP Toolkit/Widgets
(Reporter)

Comment 6

19 years ago
*** Bug 38111 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
reassigning to ben, who said he could fix the dup in 5 minutes flat.  If the 
two symptoms in this bug do need to be split out, just reopen the dup.
Assignee: matt → ben
(Reporter)

Comment 8

19 years ago
Resummarizing.

To clarify, this bug now only tracks the problem of radio buttons and 
checkboxes processing (checking) on mouseup regardless of where mousedown 
originated.  

If it hasn't already been reported, the one about being able to totally uncheck 
radio groups by clicking between the buttons should be split off into another 
report.
Summary: Mousedown/Mouseup problem with checkboxes and radio buttons → radio and checkboxes process on mouseup regardless of where mousedown originated
(Reporter)

Comment 9

19 years ago
Wait...so Peter which issue should this one track? The unchecking or the 
mousedown/mouseup problem?

Comment 10

19 years ago
Ben, is this a beta 2 blocker?
Target Milestone: --- → M17

Comment 11

19 years ago
*** Bug 38935 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

19 years ago
This bug has two issues and it's making dup-triaging extremely difficult..

(of course I blame no one but myself for this since I initially reported it)

Comment 13

19 years ago
*** Bug 40002 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 14

19 years ago
Is this a dup of/related to bug 35606?

Comment 15

19 years ago
Excellent! yes this would be a dup, and the fix works for me :-]

*** This bug has been marked as a duplicate of 35606 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 16

19 years ago
k, vrfy

john - what fix, though?
Status: RESOLVED → VERIFIED

Comment 17

19 years ago
I was refering to the fix described by brade -- make the handler 
'type="click"' instead of 'type="mouseup"'
You need to log in before you can comment on or make changes to this bug.