incorrect usage of mouseup on xul widgets

VERIFIED FIXED in M18

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Brade, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
I was talking with joki about event handling and he reminded me that clicking on 
controls and links should actually trigger on mouseclick rather than mouseup.  I 
happened to later notice that in xulBindings.xml there is code like this:

  <handler type="mouseup" value="this.checked = !this.checked;" />

joki confirmed that this is a bug (as written above).

Updated

19 years ago
Target Milestone: --- → M17
Status: NEW → ASSIGNED
Target Milestone: M17 → M16

Comment 1

19 years ago
*** Bug 37151 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
*** Bug 40553 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
Hmmm, this might be bad.  Real bad.  We should fix this for beta 2.
Keywords: nsbeta2
Target Milestone: M16 → M18

Comment 4

19 years ago
[need info] What will the user see that is bad?
Whiteboard: [need info]

Comment 5

19 years ago
A standard use case is for a user to mousedown on a checkbox or radio, change
their mind, drag away from the control and mouseup -- result is no change to 
the state of the control.

The problem is that when they mouseup "just somewhere else" and that is over
a checkbox/radio or its label, they have now changed this other control's state 
-- likely _without_realizing_ that they have done so (try it out in some of
the mail pref dialogs).

That's not good (especially as this contradicts a standard UI behaviour).
Whiteboard: [need info]

Comment 6

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
wfm on 60608 win98, win2k and linux.  waiting for mac verification...

Comment 9

19 years ago
verified on mac. Thanks Blake.
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
*** Bug 43760 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.