Closed Bug 371779 Opened 13 years ago Closed 11 years ago

Reevaluate required fields for user profiles

Categories

(addons.mozilla.org Graveyard :: Administration, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: clouserw, Assigned: wenzel)

References

Details

Attachments

(1 file, 1 obsolete file)

I've had people ask me on IRC to remove the "Last name must not be empty" requirement (and I agree it should go).  We used to require nicknames - maybe we could bring that back and remove lastname, or..?

Our current requirements are:

        'email'     => VALID_EMAIL,
        'password'  => VALID_NOT_EMPTY,
        'firstname' => VALID_NOT_EMPTY,
        'lastname'  => VALID_NOT_EMPTY,
        'homepage'  => VALID_URL_OPT
I do not use nicknames and I think I am not alone with it. Would it be possible to require at least one of firstname/lastname/nickname to be filled in?
Why do we even have more than one name field? Maybe "Nickname" and "Real name" (real name being optional and used for stuff like official communication or sending tshirts...)
Component: Add-ons → Administration
QA Contact: add-ons → administration
Target Milestone: --- → 3.x (triaged)
Duplicate of this bug: 433813
We'll change this requirement to Nickname OR First+Last.
Blocks: 457549
Target Milestone: 4.x (triaged) → 4.0.3
Assignee: nobody → fwenzel
This patch enforces our new "required fields" policy (that is, first and last OR nick) on a model level, and add a little explanation to the register and edit views as well.
Attachment #345234 - Flags: review?(clouserw)
The patch works fine, but why are we requiring both first name and last name?  Why can't it just be first or last or nickname?
(In reply to comment #6)
> The patch works fine, but why are we requiring both first name and last name? 

Hm, dunno, wasn't that what we decided on? I guess it makes sense though. We just don't want the entire thing to be empty.

I'll make a new patch.
On the other hand: We require the nickname to be unique, but not the other fields. So if someone's nickname was "clouserw", everybody else could fill that into the firstname box and imitate him. What do you say?
(In reply to comment #8)
> On the other hand: We require the nickname to be unique, but not the other
> fields. So if someone's nickname was "clouserw", everybody else could fill that
> into the firstname box and imitate him. What do you say?

I don't think that's a problem we're going to solve here.  Whether someone makes their name ". clouserw" or "c1ouserw" (that's a one right thar) there are just too many combinations of similar looking names.
This patch just enforces one of the three fields not to be empty.
Attachment #345234 - Attachment is obsolete: true
Attachment #345298 - Flags: review?(clouserw)
Attachment #345234 - Flags: review?(clouserw)
Attachment #345298 - Flags: review?(clouserw) → review+
Thanks: Committed to r19440, l10n in r19441.
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: push-needed
Resolution: --- → FIXED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.