newlines get deleted when e-mail sent

RESOLVED DUPLICATE of bug 125928

Status

RESOLVED DUPLICATE of bug 125928
12 years ago
12 years ago

People

(Reporter: dsanders1234, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: version 1.5.0.2 (20060308)

Sometimes when I compose an e-mail message and send it, the sent message runs my paragraphs together.  I generally compose without a newline until I need to separate paragraphs.

Like this.  But when I look at the sent e-mail, the two paragraphs are together (one of the two newlines seems to be deleted).  I don't add more than one newline between paragraphs.  When I look at the source of the sent e-mail, it looks fine.


Reproducible: Sometimes

Steps to Reproduce:
1. Compose several paragraphs of text without using newlines except to separate the paragraphs (one to end the paragraph and one to separate).
2. Send the e-mail
3. Go to the sent folder and look at the sent e-mail
Actual Results:  
I fixed a bug in my fix that could crop up if hourVO ever had a startDt of HE 24...
David 

Expected Results:  
I fixed a bug in my fix that could crop up if hourVO ever had a startDt of HE 24...

David 

The source of the e-mail:

From - Mon Feb 26 14:02:27 2007
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
Message-ID: <...>
Date: Mon, 26 Feb 2007 14:02:23 -0600
From: ...
Organization: ...
User-Agent: Thunderbird 1.5.0.2 (Windows/20060308)
MIME-Version: 1.0
To: ...
Subject: New in CVS again...
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

I fixed a bug in my fix that could crop up if hourVO ever had a startDt 
of HE 24... 

David

Comment 1

12 years ago
Do you compose as HTML?  Then the problem you're encountering is likely to be bug 125928.

If you compose as plain text, do you have the wrap column set to 0?  Then the problem you're encountering is likely to be bug 261467.
(Reporter)

Comment 2

12 years ago
I use the default (I assume this is HTML).  Bug 125928 has a subject line describing not deleting spaces, however upon reading the text, it sounds like it could be related, but I am not sure.  I generally hit enter after a paragraph (I don't add spaces, unless they get there from editing the email), and I am not cutting and pasting that I know of.

Comment 3

12 years ago
If there's a Format submenu under Options on the compose window, it's an HTML compose window.  (Also if there's an Insert or Format top-level menu, but those can be turned off and still be an HTML window.)

The text you pasted has a trailing space after the "24...".  While I can't say it's /impossible/ that TB is suddenly adding spaces to text you're composing, it seems far less likely than your having typed the spaces in yourself.
(Reporter)

Comment 4

12 years ago
I did a quick test, checked the message in the sent folder and found that it DOES add a space!  (At least by highlighting the text, it reveals an invisible character after the ...).

Yes, there is a format submenu (Body Text, etc.).

(Reporter)

Comment 5

12 years ago
Additional note:  These test messages looked okay in the sent folder, and there does not appear to be an invisible character in the source of these messages.  Looking at the source of the sent message that was messed up, there WAS an invisible character in the source.

Comment 6

12 years ago
I am not questioning whether there is a space in the message that's displaying incorrectly; I am questioning how it got there.  If you can provide steps to reproduce and show that there is a space added, you have a new bug.  If you can't, then my position is in the broken message, you inadvertantly typed two spaces at the end of the line before hitting Enter, and the problem you're seeing is already reported at bug 125928.
(Reporter)

Comment 7

12 years ago
I am unable to reproduce how I typed in or edited the emails that gave me the problem.  It could be the reported bug 125928.  I can get it to happen every time by adding two spaces to the end of a line and hitting enter twice before typing the next paragraph.  I could have edited my e-mail in such a way that this happened somehow, I suppose.  I'll go ahead and mark this bug as a duplicate of 125928, and just hope it gets fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 125928
You need to log in before you can comment on or make changes to this bug.