Total System Failure when I click on links or use search dialogs.

RESOLVED DUPLICATE of bug 353962

Status

()

Firefox
Shell Integration
--
critical
RESOLVED DUPLICATE of bug 353962
12 years ago
11 years ago

People

(Reporter: Sam Spencer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3
Build Identifier: Firefox 2.0.0.2

Ever since updating from Firefox 2.0.0.1 to 2.0.0.2, Firefox has become very unstable. Whenever I use the browser normally, especially with search or sorting dialogs, I get the spinning beach ball of death, to the point that I can't open or access new windows in finder, the dock, or any other program. Which means that I cannot force quit firefox, which means no talkback report is generated. I always have to perform a hard reboot, because I can't access the normal shutdown dialog. I left the computer alone for awhile, to see if it would work itself out, and two hours later it was still in the same state that I had left it. I have done a complete uninstall twice, deleting all application support folders and property lists, and reinstalled fresh from the website, and I am still having the same problems. That leads me to believe that it is not an extension that is the source. Firefox is currently unusable.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Open web page.
3. Click a link or use any search box, even the installed google search box.
Actual Results:  
system froze, hard to perform a hard reboot.

Expected Results:  
Not crashed the entire operating system!

Errors listed in Firefox's Error Log:
Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: file:///Applications/Firefox.app/Contents/MacOS/components/nsSessionStartup.js :: sss_doRecoverSession :: line 286"  data: no]
Source File: file:///Applications/Firefox.app/Contents/MacOS/components/nsSessionStartup.js
Line: 286

Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: file:///Users/unique-ish/Library/Application%20Support/Firefox/Profiles/fq46b192.default/extensions/%7B2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9%7D/components/nsYBookmarksStoreService2.js :: anonymous :: line 346"  data: no]
Source File: file:///Users/unique-ish/Library/Application%20Support/Firefox/Profiles/fq46b192.default/extensions/%7B2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9%7D/components/nsYBookmarksStoreService2.js
Line: 346

Error: Warning: unrecognized command line flag -psn_0_7208961

Source File: file:///Applications/Firefox.app/Contents/MacOS/components/nsBrowserContentHandler.js
Line: 655

System Configuration:
Hardware:

    Hardware Overview:

      Machine Name: Mac
      Machine Model: MacBookPro2,2
      Processor Name: Intel Core 2 Duo
      Processor Speed: 2.16 GHz
      Number Of Processors: 1
      Total Number Of Cores: 2
      L2 Cache (per processor): 4 MB
      Memory: 2 GB
      Bus Speed: 667 MHz
      Boot ROM Version: MBP22.00A5.B01
      SMC Version: 1.12f5
      Serial Number: W8646073W0K
      Sudden Motion Sensor:
          State: Enabled

Software:

    System Software Overview:

      System Version: Mac OS X 10.4.8 (8N1037)
      Kernel Version: Darwin 8.8.2
      Boot Volume: Macintosh HD
      Computer Name: MacDaddyPro!

Comment 1

11 years ago
Did you upgrade to the latest version? Does the problem still happen? Is so, try getting support using one of the options listed at http://www.mozilla.com/en-US/support/

Just from the report, you have some del.icio.us extension installed, might be worth trying a clean Firefox profile. I'm also not sure where does this getInterface error come from (care to click the link in the Error console and post the line it happens on?). That error shouldn't be serious though, as well as the message from nsBrowserContentHandler.

Comment 2

11 years ago
Hello all,

After carefully reading bug 375727, bug 371863 and bug 351420, I am resolving these as DUPLICATE bugs of bug 353962. From what I read in all 4 mentioned bug reports, their summary, description and external signs 
- hangs, 
- "frozen application", 
- spinning ball cursor, 
- weak stability, 
- revision version of Firefox involved clearly suggesting a regression, 
- impromptus/random occurences of hung application, 
- Machine Model: MacBookPro, 
- 2 have google search toolbar, 
- OS being OS X 10.4.x
all concur and convincingly lead me to resolve these as a DUPLICATE of bug 353962. If you strongly believe that this is a serious mistake, then you may REOPEN the bug by providing reasons, explanations, details as to why your bug should not have been resolved as a duplicate of bug 353962.

Thank you, Gérard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353962
You need to log in before you can comment on or make changes to this bug.