Last Comment Bug 371946 - Cannot delete event on network calendar
: Cannot delete event on network calendar
Status: RESOLVED INVALID
:
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Trunk
: x86 Windows Vista
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 07:24 PST by Bert Bouwers
Modified: 2007-09-12 10:11 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Bert Bouwers 2007-02-27 07:24:47 PST
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a3pre) Gecko/20070226 Calendar/0.6a1

It is not possible to delete an event through the Sunbird GUI using either right-click on the event and then selecting Delete Selected Event or by selecting the event and pressing the Delete toolbar button. Works OK for a local calendar, but not on a shared network calendar. However, creating AND changing the event, for example the end time, works perfectly well.

Reproducible: Always

Steps to Reproduce:
1. Create event
2. Select event by sigle click on the event
3. Right click and select Delete Selected Event
4. Reload Remote calendars for the selected user

Actual Results:  
Previously deleted event is visible again

Expected Results:  
Previously deleted event should not be visible anymore

Also occurs on stable build (version  0.3.1)
Maybe related to Vista?
Remote calendar is based on WebCalendar v1.1.2
Comment 1 Stefan Sitter 2007-03-03 05:42:51 PST
Are there any error messages in the Error console? 

Do you try to delete repeating events? In that case you will have to use the Delete button on keyboard due to Bug 332266, Bug 351850.

How does WebCalendar v1.1.2 stores the events? Does it have some caching mechanisms that still holds the events after being deleted in Sunbird?
Comment 2 etc 2007-03-28 11:24:16 PDT
(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1;
> .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506)
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a3pre)
> Gecko/20070226 Calendar/0.6a1
> 
> It is not possible to delete an event through the Sunbird GUI using either
> right-click on the event and then selecting Delete Selected Event or by
> selecting the event and pressing the Delete toolbar button. Works OK for a
> local calendar, but not on a shared network calendar. However, creating AND
> changing the event, for example the end time, works perfectly well.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Create event
> 2. Select event by sigle click on the event
> 3. Right click and select Delete Selected Event
> 4. Reload Remote calendars for the selected user
> 
> Actual Results:  
> Previously deleted event is visible again
> 
> Expected Results:  
> Previously deleted event should not be visible anymore
> 
> Also occurs on stable build (version  0.3.1)
> Maybe related to Vista?
> Remote calendar is based on WebCalendar v1.1.2
> 

the same happens in lightning, and is always reproducible too. I tested on win XP and 2000 and it was the same, so it shouldn't be related to Vista. 
Comment 3 Martin Schröder [:mschroeder] 2007-05-10 08:00:41 PDT
I tend to think events from user calendars can't be deleted, you can only subscribe to calendars to view events. There is also no access control for remote users. I think, you can only add (and maybe delete) on special public calendars. So WebCalendar is a nearly closed system with no real remote support.
Comment 4 cmtalbert 2007-05-24 10:01:44 PDT
This seems to be a specific issue with using webcalendar as a backend, we cannot recreate this behavior with other remote calendar servers.  

Marking this bug as INVALID (since it is not a sunbird/lightning bug).  If you find other sunbird/lightning bugs, feel free to report those.

Comment 5 cmtalbert 2007-05-24 10:13:34 PDT
Also, we found this note of interest: http://www.k5n.us/webcalendar.php?topic=FAQ#faq_6
Comment 6 Justin Leming 2007-07-06 12:46:47 PDT
I have the exact same problem, except that I am using SunBird 0.5, and Zimbra.
Comment 7 Justin Leming 2007-07-06 12:53:04 PDT
An update on my previous submission, I'm not sure if this is a problem with SunBird, or a problem with Zimbra, but apparently, if the status of the appointment is changed to "Cancelled", then it is deleted, it will work.

see:
http://www.zimbra.com/forums/migration/8221-two-way-icalendar-sync-open-source-edition-3.html
Comment 8 Lance Haverkamp 2007-07-11 16:03:27 PDT
(In reply to comment #2)
> the same happens in lightning, and is always reproducible too. I tested on win
> XP and 2000 and it was the same, so it shouldn't be related to Vista. 

Same problem in Linux 0.5 version of the lightning plugin as a stand-alone one user system, not related to server or windows. 

Lance

Comment 9 Lance Haverkamp 2007-07-11 16:06:47 PDT
(In reply to comment #7)
> An update on my previous submission, I'm not sure if this is a problem with
> SunBird, or a problem with Zimbra, but apparently, if the status of the
> appointment is changed to "Cancelled", then it is deleted, it will work.
> 
> see:
> http://www.zimbra.com/forums/migration/8221-two-way-icalendar-sync-open-source-edition-3.html
> 


Changing to canceled does NOT delete the item from lightning 0.5 under linux as a stand-alone system.
Comment 10 Justin Leming 2007-07-12 08:20:33 PDT
> Changing to canceled does NOT delete the item from lightning 0.5 under linux as
> a stand-alone system.

I did not say that it did.  I said that you had to change it to Cancelled, and then delete it.  Changing it to cancelled removes it from Zimbra, and then I also have to delete the item to remove it from lightning.
Comment 11 Lance Haverkamp 2007-07-12 08:31:39 PDT
Hi, Sorry for the confusion, I didn't mean to imply that you did say that; I meant to point-out that the same solution wasn't working in stand-alone lightning.

Hey, I noticed that this bug is now marked RESOLVED INVALID.

Any idea why, since it's neither resolved nor invalid?  Should I resubmit for lightning or how do I get it reopened?

Thanks,

Lance
Comment 12 Justin Leming 2007-07-12 08:48:42 PDT
This has been marked INVALID since post #4:

This seems to be a specific issue with using webcalendar as a backend, we
cannot recreate this behavior with other remote calendar servers.  

Marking this bug as INVALID (since it is not a sunbird/lightning bug).  If you
find other sunbird/lightning bugs, feel free to report those.

-- However, I do believe that this is NOT invalid.  Perhaps when you delete an event, and using ICS, it should mark the event as cancelled first, and then delete the event.

Lance, if you mark an event as cancelled, then delete it, does it still reappear?  
Comment 13 Lance Haverkamp 2007-07-12 14:50:36 PDT
(In reply to comment #12)
> Lance, if you mark an event as canceled, then delete it, does it still
> reappear?  
> 

Using lightning 0.5 on thunderbird version 2.0.0.4 (20070604) on Debian/Ubuntu Linux, I've added two agenda items.  One won't stay canceled, it always returns to not specified.  The other will stay canceled, but won't delete--I've tried highlighting then pressing delete & right-clicking (which does nothing).  If there's a way to delete agenda items at all, I haven't found it.

I deleted the extension & reinstalled, but it remembered the agenda items, so something is not getting deleted when the extension is uninstalled.  Strange behavior remained after uninstall/reinstall of extension.

Lance
Comment 14 cmtalbert 2007-07-13 07:49:05 PDT
Lance and Justin,

We try to keep our bugs as close to "one bug, one issue" as possible.  This business with canceling an event then deleting it on an ICS calendar may have some merit, and I encourage you to open another bug for that because most people don't watch bugs that are "closed" (such as this one is).   

The other problem that Lance identified, the "canceled item doesn't stay canceled" is potentially a very serious issue, and that should also be its own bug.  I thought it was filed, but a quick search shows me that it isn't.

Agenda items are read from your calendar and your Todo list, so in order to delete agenda items, you have to delete them from the calendar or the Todo list.  You can't delete anything directly from the agenda.

Please CC me on the new bugs that you file for these issues, gentlemen.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.