The default bug view has changed. See this FAQ.

Improve image quality on resize.

RESOLVED DUPLICATE of bug 486918

Status

()

Core
Graphics
--
enhancement
RESOLVED DUPLICATE of bug 486918
10 years ago
5 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Bug 98971 fixed major issues with image resize.
Per bug 98971 comment 146 we could improve image quality, 
especially PNG images.

See attachment 205595 [details] (quality comparison img_resize.html)
The resize algorithm used by MSPaint gives a better image than Moz...
(Reporter)

Updated

10 years ago
Severity: normal → enhancement

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 1

10 years ago
Downscaling and upscaling need different algorithms.  This one looks like it's
using an upscaling algo to downscale.

Updated

10 years ago
Flags: in-testsuite?

Comment 2

10 years ago
Downscaling on 2.0.0.4 verified to still use nearest neighbor (or something like it). Note bug 312309 likely a dup of this.

Updated

9 years ago
Flags: in-testsuite?

Updated

9 years ago
Blocks: 393966

Comment 3

9 years ago
Created attachment 347264 [details]
Resizing example

We hit the same issue in TomTom HOME, I am attaching an example. In this case we are resizing a 250x221 image to 60x53. On the left is the result in Firefox 3.0.3 (XULRunner 1.9.1b1 gives identical results) - rest are different resizing algorithms from an image editor. Second from right is "nearest neighbor" which is similar to Firefox but still a lot better.
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Flags: wanted1.8.1.x?
Flags: wanted-fennec1.0?
Flags: blocking1.9.2?
Flags: blocking1.9.1?
Flags: blocking1.9.0.9?
Flags: blocking1.9.0.10?
Flags: blocking1.8.1.next?
I report similar bug...
https://bugzilla.mozilla.org/show_bug.cgi?id=486918

IMO dev team should implement Lanczos or at last BiCubic resampling for downsizing or upscaling images for the best quaity...
This methods is not very heavy for CPU, so it should works for all ppl fine...

Comment 5

8 years ago
You won't help your cause by spamming people. The "blocking" flags are there for a reason (https://wiki.mozilla.org/Calendar:For_Everyone:Blocking_Flags), don't misuse them.
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Flags: wanted1.8.1.x?
Flags: wanted-fennec1.0?
Flags: blocking1.9.2?
Flags: blocking1.9.1?
Flags: blocking1.9.0.9?
Flags: blocking1.9.0.10?
Flags: blocking1.8.1.next?
(Reporter)

Updated

8 years ago
Depends on: 486918

Comment 6

8 years ago
I just tried specifying "image-rendering: optimizeQuality" (https://developer.mozilla.org/en/CSS/image-rendering) in Minefield build 20090807 but I don't see a significant difference. Looks like it doesn't fix this bug.

Comment 7

8 years ago
In Gecko 1.9.2 there is no difference between "optimizeQuality" and "auto" (default value), both use bilinear resampling. Will clarify that in the MDC CSS reference.

Updated

7 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
Component: Image: Painting → Graphics
Product: Core Graveyard → Core
QA Contact: image.gfx → thebes
Does this bug cover the upscaling quality difference between Mac and Linux (upscaling on Linux is notably worse than on Mac)?
FWIW, on Linux, both Chrome and Opera have nicer image upscaling than Firefox.
Any plans for implementation this in future releases next to Firefox4 ?
Because downscaling quality in the worst compared to all other browsers...
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486918
No longer depends on: 486918
You need to log in before you can comment on or make changes to this bug.