Required fields that are localized are not enforced consistently

VERIFIED FIXED in 5.0.3

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
11 years ago
2 years ago

People

(Reporter: Wladimir Palant, Assigned: wenzel)

Tracking

Details

(Reporter)

Description

11 years ago
When I upload a new add-on version and don't provide version notes in step 2 I get an error message. However, I can enter something and remove it in step 4 again - no check there.
This is true for any required field that is localized (most of them). Ideally, required fields would be checked for the default locale anytime saveTranslations() is called.

Forgot to copy this bug from grouphub.
Severity: normal → major
Summary: Version notes not enforced consistently → Required fields that are localized are not enforced consistently

Updated

11 years ago
Target Milestone: --- → 3.1
Target Milestone: 3.1 → ---
Severity: major → normal

Updated

10 years ago
Target Milestone: --- → 3.5

Updated

10 years ago
Assignee: nobody → fligtar
Depends on: 428630

Updated

10 years ago
Duplicate of this bug: 434791

Updated

10 years ago
Assignee: fligtar → nobody
Target Milestone: 3.5 → ---

Updated

9 years ago
Target Milestone: --- → 5.0.3

Updated

9 years ago
Assignee: nobody → fwenzel
(Assignee)

Comment 3

9 years ago
Is this problem even present anymore in the new dev CP? From what I see in the UI, I am unable to remove the default language from the translation fields, unlike in the old version.

If I still need to add something to saveTranslations(), where do I get a set of "required" fields?
(Assignee)

Comment 4

9 years ago
For all I can see for now, it is fixed in the new dev cp.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
^will be fixed, when the new dev cp is default. Any idea when the old system will be removed and fully replaced with the new?
Verified; always one required locale.

Wil knows more, but I think in the next milestone; we had some l10n to get out of the way, first (putting comments by each string define, iirc).
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.