Last Comment Bug 372840 - [kn, kn-IN] Kannada: Firefox
: [kn, kn-IN] Kannada: Firefox
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: x86 Linux
: -- normal with 6 votes (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
Depends on:
Blocks: 408962
  Show dependency treegraph
 
Reported: 2007-03-06 09:44 PST by H P Nadig
Modified: 2013-12-16 08:05 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
firefox-2.0.0 translated to kannada (167.09 KB, application/x-xpinstall)
2007-12-14 02:55 PST, Shankar Prasad
no flags Details
Translated files (part -1) (265.79 KB, application/x-gzip)
2007-12-18 21:42 PST, Shankar Prasad
no flags Details
Translated files (part-2) (177.42 KB, application/x-gzip)
2007-12-18 21:43 PST, Shankar Prasad
no flags Details
firefox translations in a single tarball (192.49 KB, application/x-gzip)
2007-12-19 01:23 PST, Shankar Prasad
no flags Details
Final translated files(after the necessary changes) (192.51 KB, application/x-gzip)
2007-12-23 22:17 PST, Shankar Prasad
no flags Details
Kannada translated files for review (192.86 KB, application/x-gzip)
2007-12-23 23:27 PST, Shankar Prasad
svenkate: review-
Details
Translated files (192.81 KB, application/x-gzip)
2007-12-26 23:42 PST, Shankar Prasad
l10n: review+
Details
lang pack for review (166.58 KB, application/x-xpinstall)
2007-12-26 23:43 PST, Shankar Prasad
no flags Details

Description H P Nadig 2007-03-06 09:44:54 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)
Build Identifier:  Mozilla/5.0 (Windows; U; Windows NT 5.1; csb; rv:1.8.1)
 Mozilla/5.0 (Windows; U; Windows NT 5.1; csb; rv:1.8.1)
Mozilla/5.0 (Windows; U; Windows NT 5.1; csb; rv:1.8.1) Gecko/20061010 Firefox/2.0

Hi,

  We have translated Firefox 2.0 to Kannada. We'd like to register for the translations and subsequently submit the translations.
The translations are happening here:
http://translate.sampada.net/main.php?root=369

Details of the team:
Name of the team: Kannada Translation Team
URL: http://kannada.sourceforge.net
     http://dev.sampada.net/wiki/Translation
e-mail: translation@sampada.info (Mailing list)
        hpnadig@gmail.com 

Language code: kn
Nation code: IN








Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 santosh 2007-03-16 02:09:13 PDT
*** This bug has been confirmed by popular vote. ***
Comment 2 Gervase Markham [:gerv] 2007-09-19 02:51:24 PDT
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
Comment 3 H P Nadig 2007-09-26 08:38:41 PDT
Here's confirming back again. The products we've been working on for Kannada translations are Firefox and Thunderbird. 
Comment 4 Gervase Markham [:gerv] 2007-09-27 13:56:54 PDT
Great :-) You need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
Comment 5 Gervase Markham [:gerv] 2007-10-20 09:16:53 PDT
H P: There is another bug about localising into Kannada, bug 345170, which has two other people. Perhaps you could go over there and join in? It would help us to have one team, and one bug.

Gerv

*** This bug has been marked as a duplicate of bug 345170 ***
Comment 6 H P Nadig 2007-10-20 10:47:44 PDT
It is nice to know that more people are interested. We'd be glad to work with them. 

Since we're already a team - it'd be nice if they could join us. We have more than 15 active volunteers doing translations. Much of Mozilla 2.0 has been translated to Kannada by us but yet to be packaged. We'll soon be ready with one (and also for 3.x). 

Comment 7 H P Nadig 2007-10-20 10:59:50 PDT
> Much of Mozilla 2.0 has been translated to Kannada by us but yet to be packaged.

yet to be reviewed and packaged. Missed the word. :)
Comment 8 Omshivaprakash H L 2007-10-21 07:57:12 PDT
Hi Gervase,

  I too am a member of Translation Team - translation@sampada.info. As already mentioned by HP, we are already done with translations for 2.x.
Comment 9 Shankar Prasad 2007-12-14 02:55:29 PST
Created attachment 293106 [details]
firefox-2.0.0 translated to kannada

Hi,
I have completed the firefox 2.0 translation in to kannada and also have built language pack which I have attaching with this.

Eager to know your views and comment.

Shanky
Comment 10 H P Nadig 2007-12-15 02:42:56 PST
Shankar, it is nice to know that you redid the translations. Good work. But I'm hopeful that we can merge the translations done earlier at translate.sampada.net (taken off-line at this moment) with this one at a later stage (for 3.x). 

The translations seem OK except for various typos. I'm also of the opinion that we avoid Sanskrit words as much as we can. For instance - "ಸಂಕೇತೀಕರಣ" for Character Encoding doesn't strike the right chord in the minds of a normal Kannada user. 

I didn't get a chance to install the xpi, but it seems like the package needs to be revisited. The install.rdf says:

em:id="langpack-kn-IN@firefox.mozilla.org"
em:name="English (US) Language Pack"
Comment 11 Shankar Prasad 2007-12-18 21:42:39 PST
Created attachment 293807 [details]
Translated files (part -1)
Comment 12 Shankar Prasad 2007-12-18 21:43:33 PST
Created attachment 293808 [details]
Translated files (part-2)
Comment 13 Naresh V 2007-12-18 23:32:41 PST
(In reply to comment #10)
...

> The translations seem OK except for various typos. I'm also of the opinion that
> we avoid Sanskrit words as much as we can. For instance -
> "ಸಂಕೇತೀಕರಣ" for Character Encoding doesn't strike the right
> chord in the minds of a normal Kannada user. 

...

Yes, that's my point too. As long as Kannada translators understand this it's well and good. Not everyone is brought up in a sanskritised environment at home or school.
Comment 14 Shankar Prasad 2007-12-19 01:23:34 PST
Created attachment 293816 [details]
firefox translations in a single tarball

Hi,
As per Pike's suggestions, I have removed some of the files which are not realy necessary. So by that I could able to squeez all the folder into a single. Hope that is fine.

shanky
Comment 15 H P Nadig 2007-12-19 01:33:09 PST
great. If its OK by you, Shankar, I'd like to review the translations and submit them back with modifications. 

Naresh, Om and all others CCed - if you like to have a say in the translations as well, do join in. I'll post an email on the translation list as well. 

We could merge the translations done earlier on the web interface to 3.x pack. 
Comment 16 Shankar Prasad 2007-12-19 01:34:13 PST
Comment on attachment 293816 [details]
firefox translations in a single tarball

Pike will you please this package?
Comment 17 Axel Hecht [:Pike] 2007-12-19 01:56:51 PST
So, my glance at the source from a technical side with compare-locales yields:

browser/searchplugins/list.txt is missing. Just copy that over from en-US. To clarify the conversation from irc, you don't need the xml files, but you need list.txt. bookmarks.html looks good to me, the locale code might want to be changed, though, see below.

Installer is not localized (browser/installer), which is good, as there's probably no windows code page for Kannada.

Translation coverage is at 75%, which is OK, but could get better.

The langpack descriptions that HP mentioned in comment 10 should be fixed now.

Going forward, I'd suggest to start working in patches, that way changes are easier to see and review.

I'd like to figure out which locale code to use, too. Mozilla is in general preferring to use the shortest possible locale code, and I don't think that the -IN actually makes a difference to kn-IN, so I'd suggest to just go for 'kn'.

So, after all the easy stuff, shanky and HP need to figure out who's going to drive this as the point of contact for Mozilla. Having more eyes on this is already showing good effects, but in the end, we need someone to talk to. Once you have that, mind adjusting http://wiki.mozilla.org/L10n:Teams:kn-IN with that info, and please put some English information on that page, we use that to find you, and right now, I can't read anything :-/

Thanks
Comment 18 Shankar Prasad 2007-12-23 22:17:54 PST
Created attachment 294463 [details]
Final translated files(after the necessary changes)
Comment 19 Shankar Prasad 2007-12-23 23:27:07 PST
Created attachment 294469 [details]
Kannada translated files for review

Hi all,
There was some untranslated strings remained in the the previous attachment. I have translated and attaching latest tarball of kn. And I will build the lang pack soon and attach in this bug for testing.

Pike,
For locale name either 'kn' or 'kn-IN' will do as it doesn't make much difference. And regarding the lead for translations, my self and HPN will discuss and come to some conclusion.
Comment 20 Shankar Prasad 2007-12-26 23:42:09 PST
Created attachment 294632 [details]
Translated files

oops!! sorry, there was still some errors in defines.inc, sue to which langpack was not getting installed. I thank ankit for helping me to finding out the error. I have corrected it and resubmitting the tarball and the langpack.

HPN, Omshivaprakash an Naresh,
I hope now you can install the langpack over your latest firefox browser. Just install as an addon. 
Waiting for your reviews and comments.

shankar
Comment 21 Shankar Prasad 2007-12-26 23:43:04 PST
Created attachment 294633 [details]
lang pack for review

Here is the langpack.
Comment 22 Shankar Prasad 2008-01-02 21:36:26 PST
Pike,
As for as leading the Kannada localization project is concerned, I don't mind if HPN becomes the the point of contact if I get the "cvs commit access". 

regards
Comment 23 Axel Hecht [:Pike] 2008-01-03 04:51:40 PST
I'd welcome a comment from HP here, too.
Comment 24 H P Nadig 2008-01-03 11:05:57 PST
Since Shankar is contributing at this moment, I feel that he deserves the commit access. But I hope that he would be open to suggestions and changes regarding the translations in future too. 

I'm very much interested in making Mozilla a friendly tool for native Kannada speakers by focusing on better translations that would be understood by all. I would be very glad to drive the project. 
Comment 25 Shankar Prasad 2008-01-03 21:09:02 PST
HPN,
Thanks for your words. Since I didn't had any one around to review my work, I am very glad to see the "suggestions and changes to my firefox translation",  that  indeed will realy helps me for my further work too. Also as it is the community project, I woluld love to see more and more guys involve to make the translated version of mozilla better and better for the native kannada users.

Lets join hands...

Thanks for understanding...
Comment 26 Axel Hecht [:Pike] 2008-01-04 01:59:12 PST
Great.

To wrap this up, I'd like to go for 'kn' as locale code, any objections? I comment 19 as a "no" from Shankar, HP?
Comment 27 H P Nadig 2008-01-04 02:29:55 PST
As you rightly mentioned, adding -IN does not make a difference. 'kn' as the locale code should be fine. 
Comment 28 Axel Hecht [:Pike] 2008-01-04 03:19:50 PST
Lovely, initial commit done. I generally do the initial commit, as that's the most risky check-in.

I only did one minor modification, I already replaced the locale code in bookmarks.html already.

I updated http://wiki.mozilla.org/L10n:Teams:kn (and moved the kn-IN one), too, with what I read to be the outcome of the discussion here in terms of ownership.

I'll file some follow up bugs for the actual release later today, but there are two things ready to be done:

cvs -z3 -d anonymous@cvs-mirror.mozilla.org:/l10n co l10n/kn
or add kn to your MOZ_CO_LOCALES in mozconfig, or follow http://developer.mozilla.org/en/docs/Patching_a_Localization

and there's a language pack generated as our build system would on http://l10n.mozilla.org/~buildslave/incubator, generated by the initial build on http://l10n.mozilla.org/buildbot/waterfall. If changes get checked in, that will automatically pick up those and rebuild the langpack.

There's some room for testing and tweaking, I have looked at it briefly, and I saw that at least the preference dialog and it's children need new sizes on windows. More on that in the landing bug, which I'll file.
Comment 29 raghujeeva 2013-12-15 22:51:31 PST
i too want to join in the mozilla localization develop applications,, i am student of Translation Studies,, right now i am pursuinf Ph.d in Translation Studies..
 Known Languages are: Kannada. English, Hindi, Telugu..
Comment 30 Shankar 2013-12-15 23:26:47 PST
Hi Raghu,

Thanks for your interest!

Please join Kannada Translation Team over here: http://mozilla.locamotion.org/kn

Once registered you can start translating the files online from here: http://mozilla.locamotion.org/kn/firefox/goals. Please prioritize your translation work according to the order of modules listed in the above page.

Please do not comment in this bug, as this is for the initial submission of Kannada lang pack, and it has been closed long back!

For further help you can mail me directly.

Happy translating! 

Shankar

Note You need to log in before you can comment on or make changes to this bug.