3pane,Account Selected: Edit menu should match spec

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: nbaca, Assigned: scottputterman)

Tracking

({polish})

Trunk
Future
All
Windows 95
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 2000-04-21-08M16: NT4, Linux 6.0
Build 2000-04-21-15M16: Mac 9.0

Overview: In the 3pane view select the Account level, select the Edit menu and 
the following changes should occur so it matches the spec:

1) Add
a) Select: Should appear after "Select All"

2) Change
a) Delete
- Windows: "Delete" should state "Delete Account"
- Linux and Mac: "Delete Folder" should state "Delete Account"

b) .Message Filters: Should state "Message Filters" and be enabled.

c) .Folder Properties: Should state "Account Properties" (so Account Settings is 
opened)

3) Remove
a) .Thread
b) .Flagged Messages
c) Mail/News Account Settings

4. Greyed Out
a) Once "Select" is present then it should be greyed out, since the account 
level is selected.
(Reporter)

Updated

19 years ago
Keywords: ui

Comment 1

19 years ago
Grey out:

Undo ---Ctrl+Z
Redo ---Ctrl-Y 
Cut ---Ctrl+X
Copy ---Ctrl+C
Paste ---Ctrl+V

Select All --- Ctrl+A
Select --->
(Reporter)

Comment 2

19 years ago
Jen, I wrote the bug to describe what additional items needed to be fixed. Most 
of the Edit items that you just listed are already greyed out in the current 
build, which makes Scott's life easier.

Comment 3

19 years ago
Ah, sorry about that.  I did that in the other bugs too.  Just listed all items 
that should be greyed that you didn't mention. Sorry. :-(
(Reporter)

Comment 4

19 years ago
The original statements for items 2c and 3c are correct if Account Settings is 
incorporated into Preferences:
>2) Change
>c) .Folder Properties: Should state "Account Properties" (so Account Settings 
>is opened)

>3) Remove
>c) Mail/News Account Settings

If Account Setttings is Not incorporated into Preferences then the following 
should happen:
- Edit|Folder Properties should remain and become disabled (grey)
- Edit|Mail/News Account Settings should remain
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 5

19 years ago
Item 1c: Account Properties (aka Folder Properties) 
should be removed completely due to bug# 10877.
(Assignee)

Comment 6

19 years ago
nominating as nsbeta3 polish
Keywords: nsbeta3, polish

Comment 7

19 years ago
per mail triage:  remove nsbeta3 nomination and move to future milestone.  For 
the short term, we will combine items here into three bugs (in 3pane) to address 
for nsbetat3:  1. delete, change text, move menuitems;  2. enable/disable and 
text changes on context (dynamic);  3.  accelerator keys to work.

When this bug gets revisited after the first release, we'll need to see what 
items remaining that need to be addressed.
Keywords: nsbeta3
Target Milestone: M18 → Future
(Reporter)

Comment 8

18 years ago
Marking Invalid.

It is a dupe of bug# 75622 which is basically a summary bug (it covers 3pane: 
all menu items, mnemonic and accelerator issues in the same bug). The reason for 
marking it Invalid is because I don't want to create more noise in the summary 
bug. Please go to bug# 75622 for more recent status.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

18 years ago
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.