3pane Mail Menu: Add/Change/Move/Delete menu items

VERIFIED FIXED in mozilla1.4beta

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Stefan Borggraefe)

Tracking

(Depends on: 1 bug, {access})

Trunk
mozilla1.4beta
access
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3] [see comment 35], URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Build 2001-04-11-04: NT4
Still need to check Mac and Linux.

Overview: This bug summarizes the changes that should be made to the 3pane Mail  
Menu items. It includes mnemonic and accelerator issues as well.

1. Add
a. Menu Item
- File|Netscape Address Book Sync (w/mnemonic "k"),(Bugscape# 4613, Netscape 
only)
- File|Page Setup (bug# 65871)
- View|Headers|Brief (bug# 60207)
- Search  (Bugscape# 4617, Netscape only)
- Message|Add Sender to Address Book (bug# 10860)
- Message|Add All to Address Book (bug# 10860)

b. Mnemonic
- File|New||Blank Page to Edit, needs "Ctrl+Shift+N"
- File| Attachments, need "A"
- File|Print Plus, need "l"

2. Change
a. Mnemonic
- File|Get New Message for , from "f" to "w"
- File|Offline, from "l" to "f"(so that Print Plus can have a mnemonic)

b. Accelerator
- Message|Mark|All Read (bug# 66681, from "A" to "Ctrl+Shift+C, now tbd)
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, ui
QA Contact: esther → nbaca
(Reporter)

Comment 1

17 years ago
Addition to Change category:

2. Change
a. Mnemonic
- View|Messages| "Threads With Unread" and "Threaded" are both using "T". Change 
"Threads With Unread" to "h" to match the spec.
(Reporter)

Updated

17 years ago
Depends on: 10860, 60207, 65871, 66681

Comment 2

17 years ago
Note: Print Plus is bugscape 2589

Comment 3

17 years ago
reassigning to ssu.
Assignee: sspitzer → ssu
(Reporter)

Comment 4

17 years ago
3. Delete
a. Menu Item
- Edit Draft (Currently this appears disabled. Is there anyway to remove this 
menu item unless it is a message in the Draft folder? This effects the 3pane, 
Alt-3pane and Stand Alone window)

Comment 5

17 years ago
`Edit Message' is useful whether or not the message happens to be a draft. For 
example, if I send a message to a number of people, but forget one person, I 
can select the message in my Outbox and choose `Edit Message', removing the 
original recipients and replacing them with the one I forgot. I could use 
`Forward' instead, but `Edit Message' makes me look less absent-minded by 
hiding any evidence that I'd forgotten the recipient in the first place. :-)
(Reporter)

Comment 6

17 years ago
To clarify point 3a, I was actually asking about the "Edit|Edit Draft" menu
item. Sorry for not being more clear.

I agree that the "Message|Edit Message As New" menu item should always be
available :-)

Comment 7

17 years ago
marking nsbeta1+ for 1b and all of 2.  I don't think we need to do 1a for this
release.
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1
(Reporter)

Comment 8

17 years ago
Addition to Mnemonic category:
- File|Get New Messages for|Get All New Messages, needs "G".

jglick: Currently "Get All New Messages" displays "Ctrl+Shift+T" for an 
accelerator and it appears to be working. The spec states it should be 
"Ctrl+Shift+Y". I like "Ctrl+Shift+T" because it compliments Ctrl+T for the 
File|Get Messages menu item. Could the spec be updated with this change?

Comment 9

17 years ago
nbaca, yes it should be Ctrl+Shift+T
This spec has it correct: 
http://www.mozilla.org/mailnews/specs/threepane/GetMail.html#File

I will fix the other spec. Thanks.
(Reporter)

Comment 10

17 years ago
What happen to the View|Text Size menu item? It's completely gone.

Here is a summary of what needs to be present for the View|Text Size menus:

  - Smaller, needs "m" for mnemonic, Ctrl+-
  - Larger, needs "L" for mnemonic, Ctrl++
  - 50%, needs "5" for mnemonic
  - 75%, needs "7" for mnemonic
  - 90%, needs "9" for mnemonic
  - 100% (Original Size), needs "z" for mnemonic
  - 120%, needs "1" for mnemonic
  - 150%, needs "0" for mnemonic
  - 200%, needs "2" for mnemonic
  -----------------
  - Other, needs "O" for mnemonic
(Reporter)

Comment 11

17 years ago
Additional Information on View|Text Size menu item
WinMe/Linux, 3pane:     OK 
WinMe/Linux, Alt-3pane: Not present
Mac, 3pane:             Not present, only double lines
Mac, Alt-3pane:         Not present, only double lines

Let me know if I should log seperate bugs on these specific issues.

Comment 12

17 years ago
It looks like nbaca's comments about the view | Text Size menu are covered in 78489.

Comment 13

17 years ago
moving to 0.9.2
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Reporter)

Comment 14

17 years ago
Addition to Change category:
- View|Message should state "Message Pane" to make it more descriptive.

Note: The position of the "My Sidebar" menu item might change (bug# 79639, bug# 
80861). If "My Sidebar" is moved into the same position as the other toolbars 
then View|Message Pane should also move.
(Reporter)

Comment 15

17 years ago
Addition to Mnemonic category:
- View|Messages|Ignored Threads, needs "I"

Addition to Change category:
- View|Messages submenu items are not listed in the same order as the spec.
Please refer to the spec or let me know if I should list what is expected in 
this bug.

Comment 16

17 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

17 years ago
Depends on: 85508, 85510, 85512

Updated

17 years ago
No longer depends on: 85512

Comment 17

17 years ago
Missed 0.9.3.
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 18

17 years ago
moving to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 19

17 years ago
Created attachment 47406 [details] [diff] [review]
patch #1 to add mnemonic "I" to View|Messages|Ignored threads

Comment 20

17 years ago
I've fixed a seperate bug to track the View|Messages menu item inconsistencies.
 It's bug 97504.  I'll attach patches there.
(Reporter)

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 21

17 years ago
Branch build 2001-09-10: Windows 2000

Latest update:

1. Add
 a. Menu Item
    - File|Print Preview - Ctrl+Shift+P, need "Print Preview" with "V"  
underlined.  Also shortcut: Ctrl+Shift+P.  (Bug #17006)
        
 b. Mnemonics in the sub-menus:
    - File|Get New Messages for|Get All New Messages, need "G".
    - File|Offline|Work Offline, need "W".
    - View|Messages|Ignored Threads, need "I".
    - View|Character Coding|More  - needs mnemonic but it is not specified in 
Spec.
    - when Newsgroup is selected: File|Get Next 500 News, need mnemonic - not  
"X" as Spec shows - since "X" is for Exit.

 c. Add Ellipsis
    - File|Offline|Offline Setting... (... - at the end) since it brings another 
 dialog.

2. Change
 a. Mnemonic
    - View|My Sidebar, from "b" to "M" according to Spec, but Navigator has "b".
There is conflict with View|Sort by, which also has "b".  Any way pressing on 
"b" performs no function.
    - Message|Ignore Thread, from "k" to "i" 
Keywords: nsbranch

Updated

17 years ago
Blocks: 99230

Comment 22

17 years ago
not an emojo stopper. However if sean is close to a fix then of course we'll
reconsider. But it isn't a stopper.
Keywords: nsbranch → nsbranch-

Updated

17 years ago
Blocks: 76247

Comment 23

17 years ago
I checked Alt 3-pane window on Win 2000 and Linux.
The same issues as for 3-pane.

Comment 24

17 years ago
>Spec - when Newsgroup is selected: File|Get Next 500 News, need mnemonic - not  
>"X" as Spec shows - since "X" is for Exit.

"M" for mnemonic is available. Get Next 500 News _M_essages.

Comment 25

17 years ago
>2. Change
>a. Mnemonic
>- View|My Sidebar, from "b" to "M" according to Spec, but Navigator has "b".
>There is conflict with View|Sort by, which also has "b".  Any way pressing on 
>"b" performs no function.

This conflict happened when mozilla decided to remove "My" from "My Sidebar" but 
Netscape builds kept "My". Since Moz doesn't have "My", lets leave them with the 
"b" for mnemonic. 

Change "Sor_t_ by" to "t" for mnemonic instead of "b". Sound ok?

Comment 26

17 years ago
Jennifer, actually I have a fix for this exact bug.  The patch is attached to:
  http://bugscape.mcom.com/show_bug.cgi?id=5716

Comment 27

17 years ago
*** Bug 101425 has been marked as a duplicate of this bug. ***

Comment 28

17 years ago
moving to 0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Blocks: 104166

Comment 29

17 years ago
moving to 1.0 and nominating
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.6 → mozilla1.0

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 30

17 years ago
There is Bugscape bug 5716, which depends on this one.
BTW, I am going to eliminate many separate Bugzilla bugs, which have been logged
while ago.  For convenience purposes Ninoschka opened this summary bug for 3pane
window to keep all related issues together.  But there was no time to close
original ones.  Now it is the time.  Be prepared to see a lot of bugs listed as
duplicates.

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 31

17 years ago
Created attachment 59319 [details] [diff] [review]
Add mnemonic "W" to File/Offline/Work offline

I thought adding the access key to the Communicator:WorkMode broadcaster would
fix this but it doesn't seem to work so instead the patch uses the menuitem
defined in utilityOverlay.xul instead. Subsequently I have noticed that
originally the menuitem didn't actually work, although this patch seems to fix
that as well.
Curioser and curioser...

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.9

Updated

17 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla0.9.9 → mozilla1.2

Updated

16 years ago
Depends on: 142152

Updated

16 years ago
Keywords: access

Updated

16 years ago
Blocks: 154249

Comment 32

16 years ago
I remove nsbeta1- keyword - it was for MachV.
Keywords: nsbeta1-

Comment 33

16 years ago
Now I add 'nsbeta1' keyword for Buffy. Sorry, it's faster to edit multiple bugs
at once than manually go to each and remove minus.
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1+

Updated

16 years ago
Keywords: nsbeta1

Comment 34

16 years ago
Mail triage team: nsbeta1+/adt3
Whiteboard: [adt3]

Updated

16 years ago
Target Milestone: mozilla1.2alpha → mozilla1.4beta

Comment 35

15 years ago
Summarizing the various items mentioned already in this bug.

comment 0:
1.a.
 - File|Netscape Address Book Sync  (w/ "k")  -- NO IDEA! DON'T HAVE NETSCAPE!
 - File|Page Setup  -- DONE
 - View|Headers|Brief  -- NOT DONE (bug 60207) HOWEVER... [note 1]
 - Search (toplevel menu) -- NO LONGER PART OF SPEC (Netscape only?)
 - Message|Add Sender/All to Address Book  -- NO LONGER PART OF SPEC 
       due to bug 10860[?]
1.b
 - File|New|Composer page shortcut -- DONE
 - File|Attachments mnemonic -- DONE
 - File|Print Plus -- NO LONGER PART OF SPEC (Netscape only?)

2.a
 - File|Get New Message For mnemonic -- DONE
 - File|Offline -- remains 'l' because 'print plus' no longer conflicts
2.b
 - Message|Mark|All Read -- DONE: is Ctrl+Shift+C, HOWEVER [note 2]

comment 1:
 - 'Threaded' mnemonic conflict -- DONE [note 3]

comment 4:
 - 'Edit Draft' -- NO LONGER PART OF SPEC

comment 8:
 - File|Get Messages For|Get All New Messages mnemonic -- NOT DONE

comment 10:
 - View|Size still reads View|Zoom (bug 139907) -- "Zoom" matches browser; 
   however, all submenu mnemonics are in place -- DONE

comment 11: per bug 78489, this problem is gone

comment 14:
 - View|Show/Hide|"Message Pane" -- DONE
 - View|Show/Hide|Sidebar -- NO LONGER PART OF SPEC

comment 15:  [note 4]
 - View|Threads|Ignored mnemonic -- DONE
 - View|Threads submenu items -- MATCHES SPEC [note 5]

comment 21:
 - File|Print Preview (including mnemonic) -- DONE;
        Print Preview shortcut  -- NOT PART OF SPEC
 - File|Offline|Work Offline mnemonic -- DONE
 - File|Get Next NN Messages mnemonic -- DONE
 - View|Character Coding|More mnemonic -- NOT DONE [note 6]
 - File|Offline|Offline Setting ellipsis -- NOT DONE
 - View|My Sidebar (mnemonic conflict) -- OK per comment 25:
     View|Sort By mnemonic -- DONE
 - Message|Ignore Thread shortcut -- MATCHES SPEC


[note 1] see bug 154712

[note 2] per bug 66681, current Ctrl+Shift+C may not best shortcut;
per bug 233182, this menu item might be better removed from the MESSAGE menu

[note 3] 'Threaded' on a different menu from 'Threads with Unread'; also, see 
bug 219620 [menu change, patch in progress]

[note 4] the old View|Messages is now View|Threads, spec not yet updated; this 
was bug 189543.

[note 5] this problem was spun off to bug 97504; however, that bug was never 
actually fixed, and the bug it was duped to fixed only the mnemonic issue -- the 
same basic patch as appears in this bug.

[note 6] Submenu for Character Coding is not specified in Mail Menus spec.
Presumably should follow browser's spec for equivalent menu item; browser *does* 
have mnemonic, on the 'M' in More.



Items still NOT DONE (repeating from above):
 - File|Get Messages For|Get All New Messages mnemonic -- NOT DONE
 - View|Character Coding|More mnemonic -- NOT DONE
 - File|Offline|Offline Setting ellipsis -- NOT DONE
Whiteboard: [adt3] → [adt3] [see comment 35]
(Assignee)

Comment 36

14 years ago
Created attachment 145244 [details] [diff] [review]
Fixes the remaining issues

... so this bug can rest in peace.

Contrary to the findings in comment 35, the Character Encoding|More menu item
already has an access key. (What's strange with this submenu is that all its
menuitems also have access keys which are somehow not rendered. But this would
be another bug.)
(Assignee)

Updated

14 years ago
Attachment #145244 - Flags: review?(timeless)
(Assignee)

Updated

14 years ago
OS: Windows NT → All

Comment 37

14 years ago
Comment on attachment 145244 [details] [diff] [review]
Fixes the remaining issues

compare:
Get New Messages for>Get All New Messages
Get New Messages for>my account

I think that it should say:
Get New Messages for>All Accounts

thoughts?
Assignee: ssu0262 → Stefan.Borggraefe
Status: ASSIGNED → NEW

Comment 38

14 years ago
I like that idea.

Comment 39

14 years ago
jshin fixed the _More menuitem in his patch in bug 55300.
(Assignee)

Updated

14 years ago
Attachment #145244 - Flags: review?(timeless)
(Assignee)

Comment 40

14 years ago
Created attachment 145552 [details] [diff] [review]
Fixes the remaining issues and contains timeless' suggestions

I like timeless' suggestion too, so here comes a new patch.
Attachment #145244 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #145552 - Flags: review?(timeless)

Updated

14 years ago
Attachment #145552 - Flags: review?(timeless) → review+
(Assignee)

Updated

14 years ago
Attachment #145552 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #145552 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 41

14 years ago
Verified with 1.8a-0422.  Thanks, Stefan!  And thanks, Timeless, for the 
suggested change under Get New Messages For...  very nice.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.