Closed Bug 373341 Opened 13 years ago Closed 13 years ago

Print output is truncated after certain amount of weeks/months

Categories

(Calendar :: Printing, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3pre) Gecko/20070309 Calendar/0.5pre

Print output is truncated after certain amount of weeks/months.

Steps to Reproduce:

1. Start Sunbird with clean profile
2. Select menu command File -> Print...
3. Select print layout 'Monthly Grid' or 'Weekly Planner'
4. Select custom date range and set 01-Jan-2007 to 31-Dez-2007
5. Check print preview / print output

Actual Results:

Monthly Grid: Only January 2007 to first week of July 2007 is shown.
Weekly Planner: Only Week 1 to Week 19 is shown.

Expected Results:
The full date range is printed.

Regression range:

Works in Sunbird/0.4a1 (2007-02-13-05)
Fails in Sunbird/0.4a1 (2007-02-13-08)

This seems to be regressed by checkin "Bug 351957, Bug 312084, Bug 361642: removing temp file, fixing preview without calendar view, waiting for async provider response"
During testing I noticed that the HTML read from pipe is limited to 65536 bytes. The reason is that the pipe size is limited to 16*4096 bytes if default parameters are passed to init() function. Passing PR_UINT32_MAX causes the pipe to have "infinite" space. This is basically the same solution as already used in calICSCalendar.js.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #259523 - Flags: first-review?(lilmatt)
Comment on attachment 259523 [details] [diff] [review]
rev0 - increase size of pipe buffer

r=lilmatt 
nice catch
Attachment #259523 - Flags: first-review?(lilmatt) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
BTW: Wouldn't the hex literal 0xffffffff be also valid and more readable?
You need to log in before you can comment on or make changes to this bug.