Closed Bug 373380 Opened 13 years ago Closed 13 years ago

RFE: Must have a mechanism to send imip invitations

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cmtalbert, Assigned: cmtalbert)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: thunderbird version 2 beta 2 (20070223) Lightning 0.5pre

In order for people to truly use imip and itip in 0.5, people will need to be able to "round trip" these items from Lightning to Lightning.  This means:

User X: Lightning -> Send Invitation (REQUEST iTIP method)

User Y: Lightning (or other application) -> Replies to Invitation (REPLY iTIP method)

User X: Lightning -> Recieves the REPLY.

Bug 334685 laid down the architecture for receiving a invitation on Lightning.

This bug contains a preliminary, initial attempt to handle the sending of the invitation and recognizing the reply.

The main reason that this is not finalized is that it depends heavily on which version of the event dialog is used because the two dialogs set up attendees in different ways.  This initial attempt will work for both dialogs, but it would be better to streamline our invitation approach to mesh with the prototype event dialog once it lands.

Another reason this is still initial code, is that there are some high level attendee and item issues that we will need to address in order to properly handle them.


Reproducible: Always

Steps to Reproduce:
1. Type and attendee into the Event dialog's attendee list
2. Click OK
3.
Actual Results:  
No invitations sent

Expected Results:  
Invitations should be sent
This is initial support for sending iTIP invites and is needed for iTIP to be useful at all in 0.5.  I think it would be worth our while to take this so that we can get some early feedback on the iTIP infrastructure so that we can properly address the many remaining issues for 0.7 w.r.t. iTIP.
Assignee: nobody → ctalbert.moz
Status: NEW → ASSIGNED
Attachment #258043 - Flags: first-review?(lilmatt)
Comment on attachment 258043 [details] [diff] [review]
Implements initial support for sending iTIP invitations

This has a lot of XXX issues, but some will be solved when we move to Sun's dialog.  This keeps us moving forward.

r=lilmatt
Attachment #258043 - Flags: first-review?(lilmatt) → first-review+
checked in on trunk and branch --> fixed
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
using 2007031004, creating a new invitation with attendees doesn't send any mail.
But If I create an invitation and then modify it, an invitation is sent.
that's weird !
Try using the latest Lightning and Thunderbird.

When I create a new event, add an attendee's email address, and click OK, the compose window appears. Every time.
using thunderbird version 2.0pre (20070320) fr + ligthning 0.5pre 2007032003, it's still the same behaviour.
I've got two email accounts. Each account has several email aliases.
To creat an event, I double click in the day where I wan't to had the event, I put a test subject, click on more, type an email address which is not one of my aliases and select ok.
Expected : an email invitation is sent
Result : no email invitation

After this, I edit the event and add a new attendee
this time, an email invitation is sent to the two attendees.
(In reply to comment #6)
> using thunderbird version 2.0pre (20070320) fr + ligthning 0.5pre 2007032003,
> it's still the same behaviour.
> I've got two email accounts. Each account has several email aliases.
> To creat an event, I double click in the day where I wan't to had the event, I
> put a test subject, click on more, type an email address which is not one of my
> aliases and select ok.
> Expected : an email invitation is sent
> Result : no email invitation
> 
> After this, I edit the event and add a new attendee
> this time, an email invitation is sent to the two attendees.
> 

I can confirm this.  This is more a bug with the implementation of how this was done, and less with the fact that it was done.  Therefore, I'm going to open a new bug to track this problem.
Duplicate of this bug: 378057
Status: RESOLVED → VERIFIED
Duplicate of this bug: 248156
(In reply to comment #7)

> I can confirm this.  This is more a bug with the implementation of how this was
> done, and less with the fact that it was done.  Therefore, I'm going to open a
> new bug to track this problem.

What was this new bug?

Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
You need to log in before you can comment on or make changes to this bug.