bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Wrong layout when logging in and then maximizing the window (AKA iframes not yet to be the win)

RESOLVED FIXED in 3.1

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: Oliver Saier, Assigned: fligtar)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070309 Minefield/3.0a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070309 Minefield/3.0a3pre

I suspect a script is used to get the client's window width and height and adapt the site's layout to them? If so then it somewhat fails to adapt when the window is maximized. This essentially affects the iframe and the footer (small iframe / big footer).

Reproducible: Always

Steps to Reproduce:
1. Resize your browser (not too small - look at the first screenshot)
2. Connect to http://preview.addons.mozilla.org
3. Log in and click "Developer Tools"
4. Maximize
Actual Results:  
The site doesn't look as if you had clicked "Developer Tools" from a maximized window.

Expected Results:  
The site is looking good :)
(Reporter)

Comment 1

12 years ago
Created attachment 258034 [details]
1 - Loggin in Size
(Reporter)

Comment 2

12 years ago
Created attachment 258035 [details]
Maximized Afterwards (Bug)
(Reporter)

Comment 3

12 years ago
Created attachment 258036 [details]
Maximized from the Start (No Bug)
(Reporter)

Updated

12 years ago
Blocks: 352560

Comment 4

12 years ago
(btw. if you set the affected version to "3.0", this is Remora.)
Summary: [Remora] Wrong layout when loggin in and then maximizing the window (AKA iframes not yet to be the win) → Wrong layout when logging in and then maximizing the window (AKA iframes not yet to be the win)
Version: unspecified → 3.0

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

12 years ago
Thanks for the info and sorry about the bug spam i'm not too used to bugzilla. Actually maybe i should have named the bug "Wrong layout when accessing an iframe from a small window". It was easier to compare both maximized windows but on the first screenshot the iframe looks wrong already.
(Assignee)

Updated

12 years ago
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → 3.1
(Assignee)

Comment 6

11 years ago
Fixed in r3916.

The Developer Control Panel no longer uses iframes.

You can all stop hating me now.
Assignee: nobody → fligtar
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 7

11 years ago
Well done about the iFrames.

Will have to think about the "not hating" thing though.

Comment 8

11 years ago
I know you weren't serious, but nobody hates you!

We love you and the work that you and the others do.  You can tell we have strong passions for it because we work hard to explain how we think it can be better.  Sometimes these feelings override our better judgment making us look like jerks.

Ciao!
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.