No paragraph break when <p></p> tag is used

VERIFIED DUPLICATE of bug 35772

Status

()

P3
trivial
VERIFIED DUPLICATE of bug 35772
19 years ago
19 years ago

People

(Reporter: sc, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m15)
BuildID:    2000041805

If you look at the URL and its source, when you have <p></p> as your paragraph
break signal, the Mozilla browser won't put a paragraph break between topics.
Actually, it'll do so for the first set but not the rest.  So,
1<p></p>2<p></p>3<p></p>4
 will probably end up looking like...
1

2
3
4



Reproducible: Always
Steps to Reproduce:
1.  Create a new HTML page
2.  Put 1<p></p>2<p></p>3<p></p>4 in the body
3.  Load page	

Actual Results:  It would show...

1

2
3
4



Expected Results:  1

2

3

4

Comment 1

19 years ago
I'm not sure that <p></p> should generate a paragraph break. The HTML4 spec has 
wording pertaining to empty paragraphs and how they should be treated

Reassigning to buster
Assignee: troy → buster

Comment 2

19 years ago
Could be wrong, as I often am :) But shouldn't <p></p> even though while silly 
render the same as <p/> which is to render a paragraph break only if there is 
not already one. for example <p>text</p><p/><p>text2</p> would completly ignore 
<p/> while test<p/>text2  would put a paragraph between text and text2. Seems a 
reasonable way to handle <p></p>
(Reporter)

Comment 3

19 years ago
Well, all I can offer is that the the <p></p> breaks do appear when viewed in

Netscape 4.6 or 4.7 on a Mac or Win 9x machine.  They don't on Mozilla 15 on a

Mac or Win 9x machine.



So things that should be broken up, aren't.  ESPN has a lot of this going on; so

on a Mozilla browser, you get a big jumbled mass of text.  If you look at

www.espn.com's home page and look at the news releases in the right column, it's

a long continuous stream of text rather than separated blurbs.

Comment 4

19 years ago
Just some info:
a search for </p> in bugzilla brought me to bug 14030
"<P></P> should not be ignored in NavQuirks mode {ll}"

which was later marked as a duplicate of bug 35772
"quirk relating to empty P elements should be removed"

Comment 5

19 years ago
It would only make sense to talk about an equivalency between <p/> and <p></p>
if <p> were an empty element, which it has not been for a long time... and even
then, that's XHTML, which this page would never qualify as.

No surprise that this is a proprietary-generated page.

Marking as a DUP of bug 35772 by way of bug 14030; in standard mode
text<p></p>text<p></p>text would be just texttexttext unless those <p>'s were
styled, but in NavQuirks mode, as ugly as this coding is, the <p> elements
should cause whitespace. Thanks, dark@c2i.net, for tracking those bugs down.

*** This bug has been marked as a duplicate of 35772 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.