<P></P> should not be ignored in NavQuirks mode {ll}

VERIFIED DUPLICATE of bug 35772

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 35772
20 years ago
19 years ago

People

(Reporter: nisheeth_mozilla, Assigned: nisheeth_mozilla)

Tracking

({testcase})

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh: search for other examples and evangelise, if the decision is changed), )

HTML like "Line One <P></P> Line Two" causes 2 line breaks on
navigator but only 1 in raptor.  This was causing the news headslines in the
right most column of the ESPN page to squich together vertically.
This likely has something to do with special P-element-specific code that kipp
wrote based on comments in the HTML spec.  I tend to think those comments
weren't intended quite as written, but just to require CSS-style
margin-collapsing.
*** Bug 14161 has been marked as a duplicate of this bug. ***
Whiteboard: [TESTCASE]
Status: NEW → ASSIGNED
Target Milestone: M16
Accepting bug and setting milestone to M16...
*** Bug 10079 has been marked as a duplicate of this bug. ***
Other bugs for this URL are filed as bug #25160, bug #22168 and bug #22171
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
*** Bug 21631 has been marked as a duplicate of this bug. ***
According to a strict reading of the specs, <p></p> should be ignored, which
means that in fact we should not even be causing a line break there.
Summary: <P></P> causes two line breaks on navigator, but only 1 on raptor → <P></P> should not be ignored in NavQuirks mode {ll} {compat}
I don't think the HTML spec needs to be read that strictly... and anyway, I
*think* it says "should", not "must".
That's what I said! "should"! :-)

It says: "We discourage authors from using empty P elements. User agents should
ignore empty P elements." (end of section 9.3.1)

Just out of interest, are there any other sites that use this kind of markup?
(...and could someone list them? I may wish to evangelise.)

Also, what exactly is the behaviour we want? We can't just use CSS rules, 
otherwise CSS starts bordering empty P paragraphs, and such like. And if an
author uses padding instead of margins on <P> elements, then all kinds of 
weird things start happening, none of which look like us ignoring paragraphs.
Whiteboard: [TESTCASE]
Incidentally, the fix for this should be "simply" to bypass Kipp's "ignore 
empty P elements" code if the empty <P> element is flanked on both sides by 
inline elements or anonymous inline boxes (i.e., raw text). In quirks mode 
only, of course.
Whiteboard: (py8ieh: search for other examples and evangelise)
*** Bug 21631 has been marked as a duplicate of this bug. ***
Moving bugs out by one milestone...
Target Milestone: M16 → M17
I'm not even sure this should be quirks mode only.  See the thread on www-html
beginning with http://lists.w3.org/Archives/Public/www-html/2000Apr/0024.html .
Since the rules changed, this is now a dup of 35768.

*** This bug has been marked as a duplicate of 35768 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Summary: <P></P> should not be ignored in NavQuirks mode {ll} {compat} → <P></P> should not be ignored in NavQuirks mode {ll}
Whiteboard: (py8ieh: search for other examples and evangelise) → (py8ieh: search for other examples and evangelise, if the decision is changed)
Ian, I think you missed the right bug on the DUPL. bug #35768 is about applying
style for :lang elements, no?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Err, not bug 35768, sorry. I meant bug 35772.


*** This bug has been marked as a duplicate of 35772 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Marking verified dup of 35772.
Status: RESOLVED → VERIFIED
*** Bug 49327 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.