Closed Bug 373575 Opened 16 years ago Closed 16 years ago

Certain text not exposed via at-spi

Categories

(Core :: Disability Access APIs, defect)

All
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 376887

People

(Reporter: jdiggs, Assigned: ginnchen+exoracle)

References

(Blocks 2 open bugs, )

Details

(Keywords: access)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070309 Minefield/3.0a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070309 Minefield/3.0a3pre

If you examine the page contents of the above URL in AT-POKE or Accerciser, the footer text cannot be found.  If you examine the page using the DOM inspector, it is present.

Reproducible: Sometimes

Steps to Reproduce:
1. Launch AT-POKE or Accerciser
2. Navigate to http://www.tiflolinux.org
3. Examine the page's contents using AT-POKE/Accerciser
4. Examine the page's contents using the DOM inspector
Actual Results:  
The footer (section and text) is absent in AT-POKE/Accerciser; it's present in the DOM inspector.

Expected Results:  
The footer (section and text) would be present in AT-POKE/Accerciser.

On occasion the footer does appear in AT-POKE/Accerciser.  Most of the time it does not.

When the text is visible via at-spi, you can arrow to it and read it via Orca; when the text is not visible via at-spi, you cannot arrow to it or read it via Orca.
Keywords: access
Blocks: orca
can you narrow down the page to a smaller test case?
Nian: we've tried, but we seem to keep stripping something out that makes the problem go away.  Can you not reproduce the problem?
yes, i can. do you have any other similar test case?
I don't.  Can you please try working with the given page?  Thanks!
Blocks: texta11y
Assignee: nobody → aaronleventhal
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
Note: the text is a direct descendant of the document.

I would expect the text to be part of the document object, after a couple of embedded object characters for the tables.
Nian, will you look at this?
Assignee: aaronleventhal → nian.liu
ok, i'll take it. however, it seems not possible to narrow down the test case.
I might have another test case:

1. Navigate to the Google Advanced Search Page (English): 
    http://www.google.com/advanced_search?hl=en

2. Use Accerciser or AT-POKE and view the page hierarchy.  I cannot see beyond  the first form (ending with the safe search stuff)

3. Use the DOM inspector to view the same content.  I can see the entire page.

I can reproduce this on the two machines I've tried it on.
Btw, DOM Inspector doesn't show actual accessible tree. It shows nodes that can be accessilble :).
Neo, any progress? Can you mark the bug CONFIRMED if you see the problem?
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: lsr
Ginn, can you help with this one?
Assignee: nian.liu → ginn.chen
Here's another one:  www.indeed.com.  The page contents that follow the Preferences link seem to be absent from the hierarchy.
I'm able to duplicate the results on Windows using the original www.tiflolinux.org example, but it seems to depend on what accessible object I look at first.
Aha, Ginn's fix for bug 376887 fixes this! I'm seeing a focus event on the document before we fire the state change event that indicates the document is loaded. Apparently the doc can get focused before it's finished loading.
I've posted a new patch to bug 376887 which fixes this bug. It's really the same bug -- when focus comes before page load we don't Invalidate() the cache as the page continues to load.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376887
Confirmed as fixed.  Thanks Aaron!!
You need to log in before you can comment on or make changes to this bug.