Bug 374115 (lsr)

Metabug: Bugs blocking LSR support

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: parente, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
 
(Reporter)

Updated

11 years ago
Alias: lsr
(Reporter)

Updated

11 years ago
(Reporter)

Updated

11 years ago
Depends on: 371045
(Reporter)

Updated

11 years ago
Depends on: 366438
(Reporter)

Comment 1

11 years ago
Initial priorities

bug #368322 (probably a dupe of bug #371045)
bug #370651
bug #285167
bug #348901
bug #352205
bug #369389
(Reporter)

Updated

11 years ago
Blocks: 342901
(Reporter)

Updated

11 years ago
Depends on: 374711
(Reporter)

Updated

11 years ago
Depends on: 375743
(Reporter)

Updated

11 years ago
Depends on: 376275

Updated

11 years ago
Depends on: 376348
(Assignee)

Comment 2

11 years ago
I'm surprised some of these are considered blockers for LSR:
bug 255088, bug 285167 -- these seem like blockers for GOK and Jambu, but not LSR
bug 354139 is a Windows-only bug
bug 373766 should be fixed, but how does it affect LSR?

(Reporter)

Updated

11 years ago
No longer depends on: 354139
(Reporter)

Comment 3

11 years ago
bug #255088: We were going to manipulate the scrollbar widget to scroll the page while reading it. We learned from the Orca guys that moving the Firefox caret does the same trick more easily though, so it's not much of a blocker anymore.

bug #285167: Forgot why it's on our list. There was a reason. Ignore for now.

bug #354139: OK. Removed.

bug 373766: We're getting events from sources that are no longer focused, but still have focus state set. Since we can't tell the difference between the true focus and the left over focused state, we incorrectly announce the events.
(Assignee)

Comment 4

11 years ago
Sounds like a few more should be removed (although you followed my bad paste -- bug 255088 is legit, bug 285167 is the scrollbar bug I think should be removed).

Is bug 373766 related to the focus state on documents and ATK_FRAMEs? If so, that should be dealt with when we deal with those focus bugs you filed.

Updated

11 years ago
Depends on: 376935

Updated

11 years ago
Depends on: 376938
(Assignee)

Updated

11 years ago
No longer depends on: 376935

Updated

11 years ago
Depends on: 377030
(Assignee)

Updated

11 years ago
Depends on: 371274
(Assignee)

Updated

11 years ago
No longer depends on: 285167
(Assignee)

Comment 5

11 years ago
The focus event inconsistencies are dealt with, except for the state change to clear the focused state, but that's more of a nice-to-have, not a blocker.
No longer depends on: 373766, 375743
(Assignee)

Updated

11 years ago
Depends on: 363214

Updated

11 years ago
Depends on: 360003

Updated

11 years ago
Depends on: 378076
(Assignee)

Comment 6

11 years ago
LSR has worked around the getRangeExtents problems for list bullets
No longer depends on: 360003
(Assignee)

Updated

11 years ago
Depends on: 371273
(Assignee)

Updated

11 years ago
Depends on: 378468
(Assignee)

Updated

11 years ago
Depends on: 373575
(Assignee)

Updated

11 years ago
No longer depends on: 371273
(Assignee)

Updated

11 years ago
Depends on: 371273
(Assignee)

Updated

11 years ago
Depends on: 376887
(Reporter)

Updated

11 years ago
Depends on: 379627

Updated

11 years ago
Depends on: 379747

Updated

11 years ago
No longer depends on: 379747
(Assignee)

Updated

11 years ago
Depends on: 376013

Updated

11 years ago
Depends on: 381174

Updated

11 years ago
Depends on: 381177

Updated

11 years ago
Depends on: 382021
(Assignee)

Comment 7

11 years ago
I'm going to close the LSR meta bug unless someone revitalizes the LSR project.

Let's just use the Orca meta bug to track all the Linux screen reader dependencies now: bug 374212
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.