Closed Bug 373672 Opened 15 years ago Closed 12 years ago

Round-trip change because constant folding doesn't see into parens

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 461269

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: testcase)

js> f = function() { return 2 + (3); }
function () {
    return 2 + 3;
}

js> eval("" + f)
function () {
    return 5;
}
Blocks: 352304
Most of jsfunfuzz's "mismatch" complaints are due to incomplete constant folding.  Unlike most of the other known bugs, it's hard for jsfunfuzz to ignore this kind of thing without accidentally ignoring many other things, because the syntax involved is so simple and generic.

How hard is it to fix this?
Could dup this, but I left it dep. Someone please grab bug 461269.

/be
Depends on: 461269
In current tracemonkey tip:

js> f = function() { return 2 + (3); }
function () {
    return 5;
}
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461269
You need to log in before you can comment on or make changes to this bug.