Firefox browser cannot open files with unicode names

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: jhonghua_minguo, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Following Message appears when opening .htm/.html 
files containing unicode letters with Firefox:

File not found
Firefox can't find the file at /C:/data/??.htm.

The same applies, if one of the folders in the path contains unicode characters.

You can test the filenames mentioned under reproduce with Internet Explorer, and  it will open the page and show the correct letters.

Reproducible: Always

Steps to Reproduce:
1. Ensure your Windows locale for non-unicode programs is set to English
2. Create a file named "中文-にほんご-한-Grüße.html" (minus the quotes) somewhere on the harddisk
3. Open this file with Firefox
Actual Results:  
File not found

Firefox can't find the file at /C:/Documents and Settings/user-01/My Documents/New Folder/??-????-?-Grüße.html.

Expected Results:  
Open the html file.

If you switch the locale for non-unicode programs to e.g. Japanese, Firefox can open files with unicode chars in the japanese range.
But I have many files with german, japanese, chinese, korean (also mixed in filenames).
Switching the Windows locale for non-unicode programs means you have to restart Windows.

Comment 1

11 years ago
It works for me when I open files from File->Open File. But it doesn't work when you double-click the file from the Explorer (in the OS), and (this is important) when the characters are not part of your default codepage, see bug 263570.

It seems that you're reporting thew second case. Are you talking about double-clicking the file ? Then it's bug 263570.

Updated

11 years ago
Duplicate of this bug: 388231

Comment 3

11 years ago
Draggind and dropping works fine. You can also locate the file via the built-in explorer or from File -> Open File... But somehow you can't open it from Windows Explorer.

Comment 4

11 years ago
I can reproduce on Vista too
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

11 years ago
You can reproduce it on NT and 2000 as well. That's because those OSs encode text information in UTF-16LE internally.

Updated

11 years ago
Duplicate of this bug: 390444

Comment 7

10 years ago
This bug has been fixed in Firefox v3.

Comment 8

9 years ago
does this work for you in FF 3.0 or beta? 
and also bug 359200?
 http://www.mozilla.com/en-US/firefox/all-beta.html
Version: unspecified → 2.0 Branch

Comment 9

9 years ago
(In reply to comment #8)
> does this work for you in FF 3.0 or beta? 
> and also bug 359200?
>  http://www.mozilla.com/en-US/firefox/all-beta.html

The problem has been solved.
FF3.x can open 'unicode-named' files and/or any files in unicode-named folder.
In other words, the browser accepts a path string encoded in Unicode, which I think is only natural since FF3 has dropped the win9x support and moved on to NT-based OSes for Windows.

Comment 10

9 years ago
WFM per comment 9
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.