Last Comment Bug 374140 - Software Update (Firefox 2001 -> 2002) Problem - wrong User Agents
: Software Update (Firefox 2001 -> 2002) Problem - wrong User Agents
Status: RESOLVED INCOMPLETE
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 15:57 PDT by Carsten Book [:Tomcat] - PTO-back Sept 4th
Modified: 2010-01-27 01:32 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
active-update.xml (57 bytes, text/xml)
2007-03-16 07:36 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details
last-update.log (19.48 KB, text/plain)
2007-03-16 07:37 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details
updates.xml (2.79 KB, text/xml)
2007-03-16 07:37 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details
2nd user active-update.xml (1001 bytes, text/xml)
2007-03-16 11:43 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details
2nd user updates.xml (2.79 KB, text/xml)
2007-03-16 11:43 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details

Description Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-15 15:57:16 PDT
We have several reports in Mozilla.Feedback about Update Loops (the Update will install over and over again). This is annoying for users because they think they have already Firefox 2.0.0.2 installed.

This is not a dupe of Bug 371649 (but maybe related), because i think we have a second problem here.

When you post a Message over Hendrix (http://hendrix.mozilla.org/) the User Agent is collected. The User Agent on such Reports is :

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.2

And there we have the Problem, the Build ID and rv is from 2.0.0.1, however it displays: Firefox/2.0.0.2 ...and this is also the same the user see under Help->  about Mozilla Firefox

I will try to get more information like update logs from this users. As far as i see this problem occur on Windows Systems (XP) and on en-US and other locales.

For information, one of this user reports:

"I have ran this update approximately 4 times and restart Firefox after
the download completes. Then I am asked to update with 2.0.0.2 again. I
do not know if it is not completing or what? I am having no problems
with Firefox, but do not understand why I am constantly being asked to
run this update.

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.2"
Comment 1 Marcia Knous [:marcia - use ni] 2007-03-15 15:59:34 PDT
Some of the reports in Hendrix are from l10n locales such as nl and en-GB, but en-US is affected as well.
Comment 2 Marcia Knous [:marcia - use ni] 2007-03-15 16:07:21 PDT
i briefly chatted with dougt-he mentioned that possibly they have an extension that somehow mucked with their UA or they changed it? just a thought...
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-15 18:14:06 PDT
Are all the affected UAs from windows? This might be the result of a failed update due to another instance of Firefox running under another user account. I think we've had similar bugs caused by that in the past?
Comment 4 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-16 07:36:53 PDT
Created attachment 258780 [details]
active-update.xml 

Logfiles from one user with this problem:

He has also the following extensions:
Amazing Webpage Email
Noscript
OpenBook
Print Preview
Comment 5 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-16 07:37:29 PDT
Created attachment 258781 [details]
last-update.log
Comment 6 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-16 07:37:47 PDT
Created attachment 258782 [details]
updates.xml
Comment 7 Marcia Knous [:marcia - use ni] 2007-03-16 10:01:20 PDT
The ones I reviewed yesterday in Hendrix were all Windows. But I don't think we have seen this many reports of users who kept getting pinged for another update in any previous release.

(In reply to comment #3)
> Are all the affected UAs from windows? This might be the result of a failed
> update due to another instance of Firefox running under another user account. I
> think we've had similar bugs caused by that in the past?
> 

Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-16 10:13:51 PDT
(In reply to comment #7)
> The ones I reviewed yesterday in Hendrix were all Windows. But I don't think we
> have seen this many reports of users who kept getting pinged for another update
> in any previous release.

We a relatively high amount of software update fixes in 2.0.0.2, this problem might be a regression from one of them:
https://bugzilla.mozilla.org/buglist.cgi?product=Firefox&component=Software+Update&keywords_type=anywords&keywords=fixed1.8.1.2+verified1.8.1.2
Comment 9 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-16 11:43:12 PDT
Created attachment 258807 [details]
2nd user active-update.xml

i can confirm marcias comment#7 - we have a lot of comments in hendrix and we don`t had this problem in releases like 2001 (with the update from 2.0 -> 2.0.0.1)

I have also now feedback from a 2nd user.
Extensions
McAfee site advisor 26.1 enabled,
Talkback2.0.0.1 disabled 
Yahoo toolbar 1.4.0.20070112. 

The Update Logs looks similar, both users seem to used 1.5.x (1.5.0.8) before and then installed 2.0 in the same directory and now have the problems.
Comment 10 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-03-16 11:43:39 PDT
Created attachment 258808 [details]
2nd user updates.xml
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2007-03-16 12:53:48 PDT
Let's keep this bug about the incorrect UA and keep Bug 371649 about 2.0.0.2 wanting to update to 2.0.0.2.

btw: I don't see anything obvious as to why these systems have the incorrect UA
Comment 12 Marcia Knous [:marcia - use ni] 2007-04-04 15:15:14 PDT
Here is a hendrix post that indicates the problem exists on the 1.5.0.x branch as well:

Comments: 
Your people make the internet unuseable, this download does not work.  I
am about to cease using mozilla completely.  

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.11
Comment 13 Marcia Knous [:marcia - use ni] 2007-06-06 10:21:51 PDT
In reviewing Hendrix feedback for 2.0.0.4, I continue to see posts where folks have Frankenfox user agents and are complaining about Software Update. See https://bugzilla.mozilla.org/show_bug.cgi?id=371649#c43 for a few examples. My understanding was the fix for Bug 375710 was going to cover this scenario. Perhaps  sspitzer or bsmedberg could clarify about this situation. Thanks.
Comment 14 Benjamin Smedberg [:bsmedberg] 2007-06-06 14:47:50 PDT
Marcia, there is more than one way to end up in a frankenfox situation, but since we fixed this in 2004, I wouldn't be surprised if there were people in this situation who might not be fixed until the 2005 update.
Comment 15 Benjamin Smedberg [:bsmedberg] 2007-06-06 14:48:31 PDT
or it could be caused by another bug altogether
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-27 01:32:35 PST
Most of the bugs that caused Frankenfox installations have been fixed with the exception of the ZoneAlarm Forcefield one which usually causes a completely broken Firefox when it breaks things. I'm going to resolve this as incomplete since there isn't enough info to go any further with this bug.

Note You need to log in before you can comment on or make changes to this bug.