2.0.0.2 wants to update to 2.0.0.2

RESOLVED DUPLICATE of bug 375710

Status

()

RESOLVED DUPLICATE of bug 375710
12 years ago
6 years ago

People

(Reporter: lech, Assigned: moco)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed along with bug #375710])

Attachments

(10 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Left Firefox open and the computer idle and upon return noticed that the Software Update dialog had popped itself up asking if I wanted to install the 2.0.0.2 update. The catch is that 2.0.0.2 is already installed.

Reproducible: Didn't try

Steps to Reproduce:
It seems random and operates on its own accord.
Actual Results:  
The Software Update comes up.

Expected Results:  
I shouldn't be seeing this until the next actual update (2.0.0.3).
Version: unspecified → 2.0 Branch
Please see http://kb.mozillazine.org/Updates_reported_when_running_newest_version

Does this steps from this articel (delete of active-update.xml, update.xml, and the complete updates folder) fix your reported problem ?
Before you do the steps from comment#1 can you attach the updates.log and the active-update.xml - updates.xml  to this bug ?
(Reporter)

Comment 3

12 years ago
Posted file last-update.log
(Reporter)

Comment 4

12 years ago
Posted file active-update.xml
(Reporter)

Comment 5

12 years ago
Posted file updates.xml
(Reporter)

Comment 6

12 years ago
Posted file http headers
Upon reeds request, captured with the livehttpheaders extension.
(Reporter)

Comment 7

12 years ago
Posted file install.log
(Reporter)

Comment 8

12 years ago
I accidentally installed the livehttpheaders which upon restart initialized the update procedure updating fx 2.0.0.2 to 2.0.0.2 without any problems I can notice so far. So these files are all after the fact, included is http headers reed requested.
Attachment #256381 - Attachment mime type: application/octet-stream → text/plain
Attachment #256386 - Attachment mime type: application/octet-stream → text/plain
Looks like a complete update to 2.0.0.2 was applied, and there is a valid BuildID and version from 2.0.0.1 in the serviceURL of updates.xml. Someone would have to check what the update code does to the history if there are two entries with the same version/buildid/whatever the key is. Otherwise this looks pretty normal. 
Duplicate of this bug: 371712
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372981
Sorry, bug 372981 was related, but not the same bug.
See bug 372891 comment #9 for the cause of this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

12 years ago
(In reply to comment #12)
> Sorry, bug 372981 was related, but not the same bug.
> See bug 372891 comment #9 for the cause of this bug.
> 

you mean bug 372981 comment #9 :)

Updated

12 years ago
Duplicate of this bug: 373507
I have seen enough reports of this in Hendrix that this warrants more investigation. Nominating to get it on the radar. By way of information, the users that are reporting this issue in Hendrix all seem to have the horked user agens noted in Bug 374140.
Flags: blocking1.8.1.4?
I actually just saw this 15 minutes ago. Here's the active-update.xml file before I restart.

I don't have the borked UA Marcia mentioned. Mine is:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Although the active-update.xml file shows this:

serviceURL="https://aus2.mozilla.org/update/2/Firefox/2.0.0.1/2006120418/WINNT_x86-msvc/en-US/release/Windows_NT%205.1/update.xml"

Which suggests that I have that other build ID running around in here somewhere...
Attachment #259034 - Attachment mime type: text/plain → text/xml
Ben, do you have also an updates.xml file the with history of the updates ?

From the active-update.xml it seems that the complete and partial update still have status "pending" there 

complete:
state="pending"

partial:
state="pending
(In reply to comment #18)

The complete update is selected, and I have a 7+ MB mar file in my updates folder.

Comment 21

12 years ago
My updates.xml looks just like his.
Duplicate of this bug: 375098
Provisionally blocking... Any clues, Robert or Seth?
Flags: blocking1.8.1.4? → blocking1.8.1.4+

Comment 24

12 years ago
I haven't been able to reproduce this behavior again.
(Reporter)

Comment 25

12 years ago
If memory serves me correctly, the computer which this occurred on started with 2.0.0.1. The only way I can think of to reproduce this would be by installing 2.0.0.1 on a fresh system and allowing it to update while monitoring to see what happens.
accepting and investigating.
Status: NEW → ASSIGNED
> Provisionally blocking... Any clues, Robert or Seth?

no clues yet, but busy investigating bug #375710 now, which might be related.
Assignee: nobody → sspitzer
Status: ASSIGNED → NEW
Ben and Lech:

2002 contained changes we made for supporting software update on Vista (see bug #375710 comment #22)

can you check your machine for what's in:

C:\Documents and Settings\<user>\Local Settings\Application
Data\Mozilla\Firefox\Mozilla Firefox\

and attach to this bug?
Status: NEW → ASSIGNED
about what Lech is seeing, from his "http headers" attachment, rhelmer and I noticed something very odd:

https://aus2.mozilla.org/update/1/Firefox/2.0.0.2/2007021917/WINNT_x86-msvc/en-US/release/update.xml

That is a "franken-fox" aus url, because the url schema version is 1 but the firefox version is 2.0.0.2.  That url schema version 2.

for more on this, see bug #360127.  

rob looked over the aus logs and we saw a bunch of {schema == 1, fx version == 2.0.0.x}, which is troubling.

I'm going to log a spin off bug, similar to bug #360127, but the flip side, which is to return empty updates if we see schema == 1 but fx version != 1.5.x

(Reporter)

Comment 30

12 years ago
Hey Seth,

I took a peak in C:\Documents and Settings\<user>\Local Settings\Application
Data\Mozilla\Firefox\Mozilla Firefox\

and located only updates.xml and active-update.xml along with an additional \updates\0\ directory path which is currently empty. The content of both these XML files is identical and reads as the following here:

<updates xmlns="http://www.mozilla.org/2005/app-update"/>
Lech:  thanks for checking.

Ben Turner checked on his machine, and he found the same thing:

<bent> no snippets, but i've got an active-update.xml and updates.xml file, plus an empty updates/0 folder
<bent> that's weird, isn't it? why do i have those files in appdata?
<bent> oh, and both of the xml files contain only this:
<bent> <updates xmlns="http://www.mozilla.org/2005/app-update"/>
note to ben and lech, the "two files containing <updates xmlns="http://www.mozilla.org/2005/app-update"/>" is not expected.

after a successful update, I would expect that for:

C:\Documents and Settings\mozilla\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\active-update.xml

but for:

C:\Documents and Settings\mozilla\Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\updates.xml, I would expect to see an <update> item for the last update.

I'll attach mine.
Just a quick note to mention->I saw a user report of the same type of thing happening on the 1.5.0.x branch for Thunderbird. The user is reporting getting offered the 1.5.0.10 update for Tbird over and over again (he mentions 75 times over the last 3 weeks).

Comment 36

12 years ago
Hi, just wanting to inform you, that this bug seems to persist in Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3.


Comment 37

12 years ago
Posted file Mike's update files
I've just discovered now how to add an attachment, I hope this will help.
kimura-san, bsmedberg has proposed another solution.

see bug #375710 comment #55.

working on a fix now, based on his proposed solution.
fixed along with the fix for bug #375710.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [fixed along with bug #375710]

Updated

12 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 375310
Duplicate of bug: 375710
removed blocking flag, covered by 375710
Flags: blocking1.8.1.4+
I am seeing Hendrix reports from users that claim to be seeing the same thing with 2.0.0.4. Here is one:
Comments: 
Firefox kept prompting me about the update to 2.0.0.4. I updated and
even though I have updated to 2.0.0.4, Firefox keeps prompting me to
update to 2.0.0.4.

I have updated over and over and over.

What is my problem?

Comments: 
I have Firefox 2004 already installed and yet you automatically keep
downloading and installing 7 MB of 2004 update - please stop using up my
download allowance.

Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.4
> rv:1.8.1.3
> Firefox/2.0.0.4
This Firefox doesn't seem to have completed update.
Probably, other bugs.
(In reply to comment #44)
> > rv:1.8.1.3
> > Firefox/2.0.0.4
> This Firefox doesn't seem to have completed update.
> Probably, other bugs.
> 
Its maybe Bug 374140 (Software Update (Firefox 2001 -> 2002) Problem - wrong User Agents)
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.