SVG content in atom:content/@type="image/svg+xml" causing errors

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: FranklinWhale, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

When Firefox applies the feed reading view to an Atom feed with SVG content in atom:content/@type="image/svg+xml", errors occur.

Reproducible: Always

Steps to Reproduce:
1.Load a feed with SVG content in atom:content/@type="image/svg+xml"
2.The feed reading view displays with no content (only title is shown)
Actual Results:  
No entry is displayed in the feed reading view

Expected Results:  
Either the SVG content or atom:summary is displayed
(Reporter)

Comment 1

12 years ago
PS: I think all platforms/OS are affected.
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 2

12 years ago
Created attachment 258799 [details]
Test Feed
(Reporter)

Comment 3

12 years ago
Created attachment 258800 [details]
Error Messages
(Reporter)

Comment 4

12 years ago
The error cannot reproduced in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070328 Minefield/3.0a4pre, but remains in Firefox 2.0.0.3.
Version: unspecified → 2.0 Branch

Comment 5

11 years ago
This WFM in 2.0.0.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.