need tests running on Vista machine

RESOLVED INCOMPLETE

Status

Release Engineering
General
P3
normal
RESOLVED INCOMPLETE
11 years ago
5 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm noticing a bunch of win32 reftest failures because of changes in win32 rendering, and potentially in configuration changes... for example, this simple test:

span { display: inline-block; }
<p>a<span>b</span>c</p>   vs. <p>abc</p>

fails on Vista, because one column of antialiasing on the 'b' in the first case gets cut off.
we should probably extend that to include mochitest and make check for the sake of completeness. I'll put in the IT request to get a machine spun up.
Status: NEW → ASSIGNED
Hmm, so my issue was actually caused by me having Cleartype enabled.  Disabling it fixes things.  This is tricky, because I don't know what to do here -- getting things exactly right with cleartype enabled is bound to be hard, since the win32 text rendering stuff seems to cheat a bit.

I still think we should have a Vista machine for checking these things. Just out of curiosity, did anyone try running this test on a WinXP machine with cleartype enabled?

Updated

11 years ago
Priority: -- → P3
in build triage meeting, we:

- clarified subject to be about running tests on a  Vista machine containing the new win ref platform toolset
- reassigned to QA
Assignee: build → nobody
Status: ASSIGNED → NEW
Component: Tinderbox Platforms → Testing
Product: mozilla.org → Core
QA Contact: dbaron → testing
Summary: need Vista reftest platform → need tests running on Vista machine
Version: other → unspecified
Here's a pointer to some docs that schrep is working on, which might be helpful: 

http://wiki.mozilla.org/ReferencePlatforms/Test/Vista
Did a Vista machine get setup and/or tested? I've been having Mochitests toolkit/content/tests/widgets/test_scale.xul and
dom/tests/mochitest/ajax/scriptaculous/ fail on my Vista laptop. Scriptaculous is failing spectacularly with 810 of 814 tests failing. The reftests pass on my Vista machine though.

It's also worth noting that the mochitests take longer to run on Vista than on WinXP.
No, this hasn't been setup yet. We had a VM installed but it disappeared again. I'll bump this up to get it running.
Blocks: 393112
Depends on: 374264
Fixing bug 421611 would probably make this a lot easier.
Component: Testing → Release Engineering
Product: Core → mozilla.org
QA Contact: testing → release
Version: unspecified → other
(In reply to comment #2)
> Hmm, so my issue was actually caused by me having Cleartype enabled.  Disabling
> it fixes things.  This is tricky, because I don't know what to do here --
> getting things exactly right with cleartype enabled is bound to be hard, since
> the win32 text rendering stuff seems to cheat a bit.

If this is still needed, should we:
- update build+unittest refplatform to turn off ClearType? 
...or...
- setup pool of vista machines to run unittests as a newly supported UnitTest platform?
Component: Release Engineering → Release Engineering: Future
(In reply to comment #9)
> (In reply to comment #2)
> > Hmm, so my issue was actually caused by me having Cleartype enabled.  Disabling
> > it fixes things.  This is tricky, because I don't know what to do here --
> > getting things exactly right with cleartype enabled is bound to be hard, since
> > the win32 text rendering stuff seems to cheat a bit.
> 
> If this is still needed, should we:
> - update build+unittest refplatform to turn off ClearType? 
> ...or...
> - setup pool of vista machines to run unittests as a newly supported UnitTest
> platform?


Vlad: is this still needed?
(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #2)
> > > Hmm, so my issue was actually caused by me having Cleartype enabled.  Disabling
> > > it fixes things.  This is tricky, because I don't know what to do here --
> > > getting things exactly right with cleartype enabled is bound to be hard, since
> > > the win32 text rendering stuff seems to cheat a bit.
> > 
> > If this is still needed, should we:
> > - update build+unittest refplatform to turn off ClearType? 
> > ...or...
> > - setup pool of vista machines to run unittests as a newly supported UnitTest
> > platform?
> 
> 
> Vlad: is this still needed?

Please reopen if needed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.