Closed Bug 375069 Opened 13 years ago Closed 13 years ago

This is a RFE regarding the Message Filter dialog usability for Thunderbird

Categories

(Thunderbird :: General, enhancement)

x86
Linux
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 34973

People

(Reporter: sankarshan.mukhopadhyay, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; bn-IN; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10
Build Identifier: version 1.5.0.10 (20070302)

Assuming I have multiple accounts configured in my Thunderbird and each account has a number of filters, currently I cannot migrate the filters across accounts. As an example, assume I subscribe to foobar@mailinglist.com through my account foo@bar.com and use the filters for this. Now if I change my mailing list address to bar@bar.com (which is also configured and has additional filters), I cannot change the message filter earlier set for foo@bar.com using the drop down and make it applicable now to bar@bar.com. For bar@bar.com I'd have to create the filter again and run it on the particular folder where the mails are.

Reproducible: Always

Steps to Reproduce:
1. Associate a Message Filter rule with an account configured on Thunderbird
2. Change the account
3. Attempt to change the account for which the Message Filter will be applied using drop down
Actual Results:  
The existing filters for the new account is loaded

Expected Results:  
A method should be provided whereby one can migrate Message Filters across existing configured accounts

This is an RFE and a thought since I just migrated over 70 mailing lists across accounts and hand hacked the filters. Feel free to flame or /dev/null
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: GlobalFilters
You need to log in before you can comment on or make changes to this bug.