adblock breaks layout of nearly all pages on this site

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: aaront, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4pre) Gecko/20070325 Camino/1.1b+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4pre) Gecko/20070325 Camino/1.1b+

When ad blocking is turned on, all pages on the http://www.vancouver.wsu.edu site that use their current template render badly.  The problem seems to come from the fact that the site uses a div called "masthead_links" for a chunk of links in the top right corner.  The front page is laid out correctly and is only missing these links, but all interior pages are badly broken.

This seems to be caused by the line:

div[id*="ad_links"],

in ad_blocking.css, which blocks "masthead_links".  Can this be changed so that it blocks more specifically?  This only turned up in the beta 1.1 and newer, at least that I noticed.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.vancouver.wsu.edu
2. click on any links on that page to see how badly they're broken
3.
Actual Results:  
top right links are removed and this somehow causes the left navbar to shift over to the center, pushing other content over as well.

Expected Results:  
Page should render normally, as it does with ad blocking turned off

Using default theme, no plugins.

Comment 1

11 years ago
Odd. Using version 2007032305 (1.1b+), I don't see this problem at all.

Are you sure you aren't using a custom userContent.css file anywhere?

Comment 2

11 years ago
Oh, never mind. It's any page there EXCEPT the home page. I'll fix that in the URL field ;)

cl

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yeah, we need to fix that.

The div we were trying to block was "ad_links_bottom", and smorgan said to use the more generic one ;) in bug 362330 comment 21.
Assignee: nobody → alqahira
Depends on: 372612
Status: NEW → ASSIGNED
Component: Page Layout → Annoyance Blocking
QA Contact: page.layout → annoyance.blocking

Comment 4

11 years ago
How about ^= instead of *=?
FIXED by bug 372612.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.