Closed Bug 376083 Opened 13 years ago Closed 12 years ago

build failure with --enable-glitz

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: takenspc, Unassigned)

Details

Attachments

(2 files, 2 obsolete files)

Attached patch Patch rv.1.0Splinter Review
build failure with --enable-glitz on the trunk tree.
Because |SHARED_LIBRARY_LIBS| contains incorrect paths.
Attachment #260221 - Flags: review?(vladimir)
Comment on attachment 260221 [details] [diff] [review]
Patch rv.1.0

Hmm, no, $(DIST)/lib should be correct -- if the libraries aren't ending up there than that's a different issue.
Attachment #260221 - Flags: review?(vladimir) → review-
It appears they are not ending up in the right place.  

$ locate libmozglitz
/Mozilla/suite_objdir/gfx/cairo/glitz/src/glx/libmozglitzglx.a
/Mozilla/suite_objdir/gfx/cairo/glitz/src/libmozglitz.a

which causes thebes to **** out with file not found.
(In reply to comment #2)
> It appears they are not ending up in the right place.  

Is this the reason?
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/gfx/cairo/glitz/src/Makefile.in&rev=1.5&root=/cvsroot&mark=91#47
Duplicate of this bug: 389175
Still doesn't build:

gcc -o glitz_glx_drawable.o -c  -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\"
-DOSARCH=Linux -I. -I./.. -I. -I. -I../../../../../dist/include/glitz
-I../../../../../dist/include   -I../../../../../dist/include/glitzglx
-I../../../../../dist/include/nspr     -I../../../../../dist/sdk/include   
-fPIC  -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-pedantic -pipe -fno-strict-aliasing -pthread -pipe  -DNDEBUG -DTRIMMED -pipe  
-include ../../../../../mozilla-config.h -DMOZILLA_CLIENT
-Wp,-MD,.deps/glitz_glx_drawable.pp glitz_glx_drawable.c
gcc -o glitz_glx_format.o -c  -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\"
-DOSARCH=Linux -I. -I./.. -I. -I. -I../../../../../dist/include/glitz
-I../../../../../dist/include   -I../../../../../dist/include/glitzglx
-I../../../../../dist/include/nspr     -I../../../../../dist/sdk/include   
-fPIC  -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-pedantic -pipe -fno-strict-aliasing -pthread -pipe  -DNDEBUG -DTRIMMED -pipe  
-include ../../../../../mozilla-config.h -DMOZILLA_CLIENT
-Wp,-MD,.deps/glitz_glx_format.pp glitz_glx_format.c
In file included from glitz_glxint.h:30In file included from glitz_glxint.h:30,
                 from glitz_glx_drawable.c:30:
./../glitzint.h:29:28: cairo-platform.h: No such file or directory
,
                 from glitz_glx_format.c:30:
./../glitzint.h:29:28: cairo-platform.h: No such file or directory
glitz_glx_drawable.c: In function `glitz_glx_create_drawable_for_window':
glitz_glx_drawable.c:156: warning: comparison between signed and unsigned
glitz_glx_drawable.c: In function `glitz_glx_create_pbuffer_drawable':
glitz_glx_drawable.c:191: warning: comparison between signed and unsigned
glitz_glx_format.c: In function `glitz_glx_find_drawable_format_for_visual':
glitz_glx_format.c:420: warning: comparison between signed and unsigned
gmake[6]: *** [glitz_glx_drawable.o] Error 1
gmake[6]: *** Waiting for unfinished jobs....
gmake[6]: *** [glitz_glx_format.o] Error 1
gmake[6]: Leaving directory `/cache/mozilla/gfx/cairo/glitz/src/glx'
[Step 1] I am posting these steps because it worked for me. This consolidated (See Step 2 that follows) quick-fix has been confirmed with Mozilla Firefox-3.0 Beta 4 built on Ubuntu 7.10 Gutsy Gibbon only; so it may fail on other platforms. I have also included the contents of my .mozconfig file for reference. I expect somebody might find the extra details too useful...

Problem/Error:
	<mozillafirefox-3.0b4>/mozilla/gfx/cairo/glitz/src/glx/../glitzint.h:29:28: error: cairo-platform.h: No such file or directory
Solution:
	Patch <mozillafirefox-3.0b4>/mozilla/gfx/cairo/glitz/src/glx/Makefile.in
	In <mozillafirefox-3.0b4> directory, execute:
	patch -p0 mozilla/gfx/cairo/glitz/src/glx/Makefile.in Makefile.in.patch1

_________________________Contents of .mozconfig file___________________________
mk_add_options MOZ_CO_PROJECT=browser
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj_firefox_3_glitz

CFLAGS="-g"

ac_add_options --enable-application=browser
ac_add_options --enable-optimize
ac_add_options --disable-airbag 
ac_add_options --disable-libxul
ac_add_options --enable-glitz
ac_add_options --enable-pangocairo
_______________________________________________________________________________
[Step 2] This step follows [Step 1] and completes the quick-fix for glitz build failure.

Problem/Error:
	make[6]: *** No rule to make target `../../../dist/lib/libmozglitz.a', needed by `libthebes.so'.  Stop.
Solution:
	Patch <mozillafirefox-3.0b4>/mozilla/gfx/thebes/src/Makefile.in
	In <mozillafirefox-3.0b4> directory, execute:
	patch -p0 mozilla/gfx/thebes/src/Makefile.in Makefile.in.patch2
Patch "glitzbuild.diff" (equivalent to [Step 1] Makefile.in.patch1 and [Step 2] Makefile.in.patch2 from my previous posts)  generated with  "cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:2401/cvsroot diff -u8p mozilla > glitzbuild.diff".

These patches are just consolidations of patch-submissions by Takeshi Kurosawa (Attachment 273707 [details] [diff] for Bug 389175) and Boying Lu (Attachment 260221 [details] [diff] for Bug 376083).
Attachment #311549 - Attachment is obsolete: true
Attachment #311550 - Attachment is obsolete: true
Attachment #311968 - Flags: review?(vladimir)
Chances are this will become WONTFIX -- glitz won't be the way forward for us for OpenGL/accelerated support, and what little bits of code are in there right now don't work very well (with or without build patches).
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
vlad: if you're going to unsupport glitz, can we remove that configure option?
You need to log in before you can comment on or make changes to this bug.