crash [@ nsMacEventHandler::HandleMouseMoveEvent] when browser window closed and contextual menu showing

RESOLVED DUPLICATE of bug 353716

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 353716
11 years ago
7 years ago

People

(Reporter: Kieran, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

If a contextual menu is selected via ctrl+click or right click and the browser window is closed via the close box in the title bar then Firefox crashes. Sometimes it takes two attempts before Firefox will crash.

Reproducible: Sometimes

Steps to Reproduce:
1.select a context menu via right click or ctrl+click
2.without selecting anything from the context menu close the window
3.you may need to repeat steps 1-2 once more (will def crash on 2nd attempt)
Actual Results:  
firefox crashes

Expected Results:  
window should close, context menu should be dismissed
(Reporter)

Comment 1

11 years ago
update: I tested this further while waiting for some takeaway indian food and it turns out my first report is slightly innaccurate, it appears that the context menu needs to be selected via right click and the bug seems to NOT occur when ctrl+click is used instead.
(Reporter)

Comment 2

11 years ago
*crash* OK I was right the first time, ctrl+crash is affected too, but the bug isn't triggered everytime and may be less frequent under these conditions.

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

WFM. I tried about ten times, with various types of context menus (normal page, image, bookmarks, selected text) but no joy. 
Mac only issue?
(Reporter)

Comment 4

11 years ago
I also tested under windows and it does seem to be Mac only. Possibly Intel Mac only actually.
(Reporter)

Comment 5

11 years ago
Comment #2 should read 'ctrl+click' not 'ctrl+crash', I was enjoying a curry and not concentrating fully when I typed that.
If it's crashing, can you please paste a crash log into this bug? See http://www.caminobrowser.org/support/bugzilla/#crash but replace "Camino" with "Firefox".
Keywords: crash
(Reporter)

Comment 7

11 years ago
Created attachment 260881 [details]
Crash Reporter output
This is a dupe of bug 353716 and will be fixed in Firefox 2.0.0.4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: crash when browser window closed and contextual menu showing → crash [@ nsMacEventHandler::HandleMouseMoveEvent] when browser window closed and contextual menu showing
Duplicate of bug: 353716
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMacEventHandler::HandleMouseMoveEvent]
You need to log in before you can comment on or make changes to this bug.